CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

Impossible to edit existing posts

Something is broken. I cannot edit any existing posts. Whether you make any changes or not, when you click on the save button, I get a large black box with a lengthy error msg.

Notice: Trying to get property of non-object in /var/www/frontend/applications/vanilla/controllers/class.postcontroller.php on line 701 {“Code”:2,“Exception”:“First parameter must either be an object or the name of an existing class”,“Trace”:"#0 [internal function]: Gdn_ErrorHandler(2, ‘First parameter…’, ‘/var/www/fronte…’, 431, Array)
#1 /var/www/frontend/applications/vanilla/controllers/class.postcontroller.php(431): property_exists(false, ‘CommentID’)
#2 /var/www/frontend/applications/vanilla/controllers/class.postcontroller.php(701): PostController->Comment(NULL)
#3 [internal function]: PostController->EditComment(‘29559702286576’…

Can’t seem to capture the entire diatribe to post here. Does the same thing whether on mobile or full site.

Hi,

Thank you for letting us know about this. I wrote to the tech support fellow to tell him about this problem, but I’d only heard about it from a couple of people. Everyone else: PLEASE tell me if you’re having a similar or identical issue.

I haven’t been able to duplicate it on my computer or my phone, so your feedback is important.

I can’t edit either, but in my case it is because I cannot post to CarTalk using safari at all anymore and the edit is not supported by TenFourFox (FoxFire for older mac"s).

No problem here, thankfully.
In case the computer boffins need to see any type of pattern, I am using IE 9.0.8112.16421.

I lost my little “tools” gear too. I guess I’ll need to reread my posts better before posting so I don;t embarass myself!

I’m using IE 8 and had the same problem; tried to edit an error in a post and got the black box with the gibberish. At the second attempt, my post became deleted.

Also, as long as we are here, when I use dialup, I can not access CarTalk with Firefox. get the Server Not Found message; must use IE to access CarTalk with dialup.

I told youall about that problem on 7/17 in the community update section.
Today I still cannot edit posts and get the same black box messege.

Firefoxis working ok for me, soon to edit misspelling. edit I meant firefox is working for me. Next edit version 14.01

I can edit posts (I just tried it). I use Google Chrome 20.0.1132.57 in Windows Vista Hone Premium. Just in case it matters, Carolyn.

@ken green, I have been working on it. Latest request I got was for those having difficulties editing comments should provide examples of the URLs for the comments they tried to edit. Can you provide some links? I know you told us about the problem on 7/17. It’s been hard to pinpoint the actual issue, because not everyone is having the problem.

@Mr Mountainbike, you don’t see the gear in the upper right corner of your comment when you hover over it with your mouse? Click on the gear and the edit option pops down.

@Wha Who?, can you give me links to comments for whcih you got the message?

PS, thanks to all of you who responded. :slight_smile:

New error messege on last two attempts to edit in '‘law suit’ and ‘lincoln won’t go into park’
threads.
A red banner over the top of the post ‘’ unable to find thread for editing’'
tried to edit this post too

correction
"failed to find discussion for commenting"
are the words in the red banner as I attempted to edit THIS last post.
so I had to type a new one.

thanks, ken!

Here’s a new twist.
In the ‘octane’ thread I tried to edit my post to correct ‘but’ to ‘buy’.
I got the red error bar.

But when I navigated away to read other threads and came back…
it was corrected as I intended after all.

?
?

I think after looking at editing in ie and firefox and not having a problem, it is probably due to an antivirus or internet protection software, I run McAfee 8.7i virus scan enterprise, if you are having trouble please let us know what your AV software is. It may be as simple as adding this site to your trusted sites. Start control panel internet options security trusted sites sites then add site, let me know if it works. you can copy and paste address, but go to the end and hit backspace until you are at .com
Edit IE was hosed at edit as described, try firefox, avoid the workarounds.

No problems at all with IE 9.0.8112.16421, so perhaps those with an older version should download a newer version of IE from the Microsoft website.

xp is depricated to ie8, so if you are among the xp users that will not help. As state previously,

Running IE Version 9.0.8112.16421 and there’s been multiple problems over the last 3-4 weeks.
These problems come and go at will and include:
2 boxes for responses; one large and one small.
a yellow error message box that has disappeared as of today sometime but has done this in the past, only to resurface at some point.
a gear in the top right that is visible and sometimes it is not visible. at other times it’s not there at all.
when clicking that gear (when visible) sometimes (seldom) it will show “edit” and most of time shows “report”.

Excuse the grammar, lack of caps, and so on.

Just get firefox already, I banned IE so long ago as it is dangerous and unstable and a threat to the operating system.