Posting Problem


#1

Recently, when one tries to post, an error message is displayed. If you go back and hit the post button again, you get the same error message, again and again…This action results in multiple posts…There is no escape until you re-load the forum…


#2

I had another weird problem. I did an edit to correct a mis-spelling. When i clicked on the box next to the word cancel, I think is said something like “post…”, it saved my changes but populated the “Write Comment” box with a duplicate of my post. I hit my back button to see what would happen, then went to the post I had just written. Everything is ok, changes made, but I thought it was a bit confusing.

I would expect to see a “Save Changes” box and that when that box is clicked on, I would see the usual display after posting a comment.


#3

Now when I clicked on :Post Comment" this time, I got this in my browser window.

“Fatal error: Call to a member function GetUserPermissions() on a non-object in /var/www/frontend/applications/vanilla/settings/class.hooks.php on line 114”


#4

Got it again, but the posts go through OK.


#5

Now I’m getting that every time I post.


#6

I managed to get past teh problem by hitting “save draft” and then backbuttoning and reopening. But yeah, there’s a glitch.


#7

I tried to reload the forum, it didn’t help. I logged out and back in so lets see if this works.


#8

Nope, still not working.


#9

I just ran into that problem myself. Very buggy system.


#10

~ Ok - if you get the “fatal error” message, don’t back up and try to post again. Apparently it posts anyway despite the “fatal error” - as Caddyman noted


#11

Bump


#12

Is this still a problem? I noticed it started around 5ish.

Edit: I see it is.


#13

Bump


#14

Bump


#15

Seems to be fixed now.


#16

Unclear what caused it, but let us know if it resumes.