Where can I find an instrument panel for a 97 Accord?

My old '97 Accord has a dead instrument panel. I know so because we took it to the local dealer to get the speedometer/odometer fixed. They replaced the speedometer sensor and it worked for about a half a mile then quit again. When I told the service manager, he said it must be a dead IP. They’re not available anymore from Honda, but he had a used one he’d recently purchased for his own 97 Accord, so he put it in my car. No dice. He’s bought two more salvaged instrument panels since then and none of them work.
So we still have no speedometer and an odometer that works intermittently. Does anyone know of an aftermarket alternative? I’d even consider a fancy pants digital readout panel that could be plugged in as long as it gives correct readings of speed, mileage, fuel, and temperature.
And as long as it doesn’t cost an arm and a leg. A couple of toes is my limit.
Thanks in advance. :slight_smile:

A junk yard is a good source. There are several on line search engines for it, where you tell them what you need and they’ll email junk yards for you.

It may only cost one arm but you have two anyway, right?

The speedometer/odometer have a driver as part of the instrument cluster that recieves a signal from the Vehicle Speed Sensor. If there are no other drivabilty issues with the vehicle, then have them check the orange wire out of the VSS plug to the driver for the speedometer/odometer.


We don’t need no stinkin gauges, plan b.

I’m beginning to think today’s electronic cars have a built-in termination date, like the Replicants in Blade Runner…You get so many cycles and that’s it…

If you’ve now tried 3 different clsuters and none of them work properly and your’e certain that the problem is in the instrument cluster I suggest you have the cluster tested and repaired accordingly. There are a number of companies that specialize in this. Here are 2 in my area:

Please clarify, do you have a dead speedometer/odometer or do you have a dead instrument panel. Does the tach work? How about the warning lights, if you just turn the key to run but do not start the engine, do they come on? How about the gas gauge and the coolant temperature gauge?

If you’ve tried several and none of them work, I’d start looking elsewhere for the problem.

I go along with keith about wanting to know if this problem is related to the speedo/odometer only or whether other features are also out; even intermittently.

“Dead panel” to me denotes more than one feature out.

I tink we need to go back to square one. do you have a factoorey service book for your car? our there any Honda owners forums out there for the accord ? has there been any large repairs done to your car lately? i would start at the vss andcheck the plug and the warning harness and the grounds and also the fuses. when all else fails always go back to the basics.double check what Keith posted again.

I ended up buying a used IP on Ebay and having it installed by the dealer. It worked! For about 5 miles. Now it’s pegged at 20mph whenever we drive it. I would really love to have someone just pull it out and FIX it.
Thanks for the links, Asemaster. I’ll check out those companies and see if they can help.

We had a spammer awhile back that was basically advertising for his company that rebuilt, tested, and then resold instrument clusters. It sounds like you have a more severe problem perhaps feeding too much voltage or amps into your instrument cluster, in effect burning it out. A google search should give you resellers of instrument clusters, but until you figure out the real problem, likely damage wiring somewhere, you are likely to just burn out another cluster.

Aren’t there portable GPS units that give you speed readings ?
Probably a lot cheaper than getting your car fixed and you would get a GPS to boot.

I’m with the others that have suggested that multiple IPs might not be the problem, that something else is causing the problem.

Replacing the panel 3 times while having the same problem continue and making a total of 4 alleged failures is a bit disjointed. The possibility of another cause should have been considered; say a fault with the VSS wire connector plug, the drive for the VSS, etc.