CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

Defective instrument cluster?

I have a 2002 Daewoo Lanos, which I recently purchased. The car runs well, and has approximately 80,000 miles on it. I have noticed that the gauges do not work properly. The temperature gauge only goes to 1/3, however I have confirmed with a scan tool that the engine reaches proper operating temperature. The fuel gauge only goes to 2/3 when full. And the speedometer “hangs” at 30 MPH for any speed from 30-52, then “jumps” to 52 when that speed is reached, and increases normally past that. That is my biggest concern, because many roads here have speed limits of 30-40 MPH.

I assume the instrument cluster itself is defective, but want to be sure before I swap it out. Also, I bought a used one, which has 142,000 miles on it. Is it feasible/worthwhile to try to adjust the odometer back to the correct mileage, or am I more likely to ruin it by trying?

02 Daewoo… I’d be looking for corroded ground connections before worrying about swapping out another cluster from an equally old Daewoo.

As far as the mileage, NO one cares besides you. Really. 17 year old car from a company that no longer exists with an incorrect odometer reading isn’t going to bother a soul. It is truly amazing that it even still runs. It will be even more amazing if that 2nd cluster actually works better than the one in the car.

You can fix all your dashboard problems in one fell swoop by using the Torque Pro app on an android tablet with a GPS chip and bluetooth. The GPS will provide you with generally accurate speed, the bluetooth will allow you to install a dongle to access all the data on the OBD2 line plus it can do MPG and estimated miles to empty and MAY be able to read fuel level as well - not sure, never used that feature. Attach it over the cluster or in a holder of some sort and drive on.

1 Like

I will check all the ground wires, and may replace the battery since it’s 5 years old, and might fail soon anyways. I guess I will try the other cluster as-is and see how it works.

I am posting an update. I tried the other cluster and speed and temperature worked well. The fuel gauge still read lower than it should. It sounds like I will have to replace the fuel pump assy, if I want an accurate fuel gauge. I am going to the “you pull it” yard today, so I will buy another cluster to see if maybe it’s just the fuel gauge itself. Plus, I will see how difficult it is to change the fuel pump on this model.

1 Like

It still exist, but has changed name to Chevrolet, so unless GM has closed the Korean company, it still exist - sort of.

True… but do you think Chevy is going to stock 17 year old parts for a company they bought? Sort of like expecting that Chinese company that bought Saab to supply parts and support for early cars. I don’t think they will.

1 Like

I don’t believe they do that for their own production line either.
With regards to SAAB, production of spare parts is owned by ORIO AB in Sweden, bought from Nevs, China, selling parts to them also as OEM parts as ORIO owns all the original manufacturing tools for spare parts.
So for an unknown time there will be parts for SAAB’s a’plenty.

1 Like

So I went to the “you pull it” yard today, and got practice changing the fuel pump. It’s located behind a round plastic panel under the back seat, so no need to let down the gas tank (yay!).

It had already been replaced, and had a 2012 date code, so I bought the used fuel pump, and also got an instrument cluster with 88,189 miles, which is probably as close as I’m going to find anywhere. I also got a bunch of other spare parts for this car, since the row of cars it’s in has been there since June and is scheduled to be crushed this week. I guess my next step is going to be locating a new rubber O-ring for the fuel pump, and buying the special tool, so I don’t need a hammer and screwdriver to rotate the lock ring into place.

With these symptoms first step is to make sure the battery and charging system are working properly. Before first start of the day the battery should measure about 12.6 volts. Immediately after starting the engine, 13.5-15.5 volts. If you measure anything significantly different from that , post the data.

When there’s multiple gauges reading low that makes me think the IP voltage regulator is the problem. The gauge accuracy relies on a very accurate voltage reference. The battery voltage isn’t accurate enough, so a special circuit on the IP called a precision voltage regulator is used. If that voltage was too low it could cause all the gauges to read low. As noted above a grounding problem could be involved too.