Fatal error: Call to a member function GetUserPermissions() on a non-object in /var/www/frontend/app


#1

Fatal error: Call to a member function GetUserPermissions() on a non-object in /var/www/frontend/applications/vanilla/settings/class.hooks.php on line 114


#2

We’ve passed on the info to the forum’s developers to take a look at it. Until then, the moderators will try to clean up the double and triple posts. Thank you for your patience.


#3

Same thing happened to me a few times a short time ago when I tried to post in thread “Need VERY short-term basic auto liability…” I’m pretty sure the system message I got was identical to the one Common Sense Answer entered above. But then, two of my attempts appeared in the thread. Can’t be sure, but he may be referring to the same thread, as he responded to my first attempt that appeared there.

edited: got the message here when hitting "post comment:"
Fatal error: Call to a member function GetUserPermissions() on a non-object in /var/www/frontend/applications/vanilla/settings/class.hooks.php on line 114


#4

It happens every time.


#5

Yes - and it has been discussed a whole bunch of times. Don’t hit the back button and then submit again. Just reload the page after the error - your comment actually gets posted.

Good choice of a screen name.


#6

It’s somehow related to the little yellow box that says “1 new” or whatever. It does not reset to zero when you post. It resets to 1…If you just read a thread and don’t post, it resets to zero…


#7

Funny, it only seemed to happen on the iPad and I thought it was just that factor. Informative to to hear it was a site problem.