CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

OBD2 Scan tool not connecting

I got a 2009 Cobalt from my son that I am trying to repair so I have a starter car for my daughter. The check engine light is on. I connect my OBD2 scan tool to the port, but it does not connect and read the data. I have searched the web and found the fuse under the hood associated with the cigarette lighter/auxiliary port and checked this fuse. I have also checked several around them. Any ideas as to why it still isn’t working?

If the car’s OBD2 communication network has failed, you won’t be able to connect. Is just the CEL on, or other lights as well?

Which leads to the next question… Does your scan tool work on any other car?

Yes, and exactly what kind of “scan tool” are you trying to use, and how old is it?

Well . . . ?!

Did you visually check it?

Did you use a 12V test light to verify it’s hot on both sides?

You should also use the 12V test light on the data link connector itself. You might have a situation where that fuse is good, but there’s still no power at the dlc

If I were you, I’d also do as @Mustangman suggested . . . make sure the scanner actually works, by connecting it to some other OBD2 vehicles

1 Like

You have to turn the ignition switch to the on position.

1 Like

The scan tool works fine on other cars as well. Just the CEL light is on.

Not sure of the brand, but the tool is about 10-15 years old.

I did not use a check light. However, if the cigarette/auxiliary fuse/port was bad, would my auxiliary port not work as well? It is working in the car.

You should check to be sure the car is supported by your scanner and its current software revision. All of my scanners have required software updates to support various models and fix bugs. A brand new unit built in 2019 needed a software update before it would communicate properly with my 2008 truck…

I just looked and I am using a Toptak? Code scanner TP-150.

My professional level scanner can still communicate with “global obd2” even if the specific model year and/or vehicle isn’t listed

Possibly could be the battery and or connection. I had a situation with a Windstar a few months back that wouldn’t connect. It has a bad battery. It worked well enough to start the van but it ran very poorly. I checked the battery and it was barely at 10v. Swapped a new battery and then my reader worked afterward