Astroroof not working

cadillac
eldorado

#1

My 1990 Eldorado has a sunroof that has stopped working. I can press the switch and hear a slight click but no other movement or sound. Any ideas on how to repair? parts needed?

Thanks!


#2

The only way to repair it is to replace the sunroof cartridge. That means the entire sunroof assembly.

Tester


#3

19 years is long enough for anyone to work. Only humans are dolt enought to work longer.

Seriously, unless the plug connecting the sunroof assembly has deteriorated from the weather and the connection has gone bad, you’ll probably need a new sunroof assembly. The click suggests there’s power to the assembly, so it probably isn’t a wire. I hope it stopped in the closed position.


#4

Yes, it worked when I first bought the car a few weeks ago. The previous owner said it usually took a few tries on the switch to get the roof open/closed, but that it always worked. When I took ownership, it worked as he said … but only once. Thankfully, it stopped in the closed position.
I don’t really use the sunroof, so it isn’t a big deal — just wanted to fix it if I could. I like for these older Caddies to be treated right (-: Is the sunroof assembly the same as the actuator, or are we talking basically putting in a whole new sunroof – motor, tracks, etc.? That would be very expensive, I am sure. Thanks for your help!


#5

You’re talking about a whole new sunroof.

But first try something. because everything has to lay flat, the connecting plug to the sunroof assembly will be plugged into the side of the assembly. If the operating switch is somewhere above your head the same will be true of that too. Try pressing the areas surrounding the switch and the sunroof. If the plug has become loose over time, that may cause the connection to be made and the roof to operate. Then at least you’ll know that you don’t need a whole new roof.

Don’t laugh. I’m not “off the wagon”. I’ve done this.


#6

I will try it and post back. The previous owner said it took several tries to make a connection but that the roof would always work. I have made it move only once. It took several tries with the switch, and the roof had no problem sliding back and forth. It is definitely a connection issue, and it could be a loose connection. I’ll let you know! Thanks!


#7

Ok, I tried pressing on the roof (rear vent feature) and also all along the switch panel area. I still hear a click when I press the switch, but nothing moves. The roof did open for me the day I bought the car and then did not want to close until I had pressed the switch several times. Since then, however – nothing. Could the relay be bad? I saw one on a parts website for $50 – it might be worth a try??? Where is the relay located on the car? Thanks!