2011 BMW 335 stalls while moving in traffic


#1

Here’s what happened:

Description of 2011 BMW 335i engine stall in traffic 9/29/14:

Driving 40mph, smoothly at consistent speed, in middle lane of 3 lane road during morning rush hour, no stops or turns. I had been driving for about 10-15 minutes after car had been in garage the night before. Attempted small acceleration, car did not respond, engine had turned off unclear if before or at time of attempted acceleration. Power steering was off. I put on my hazards, slowly drifted to stop, put car in park, attempted restart, first attempt failed, waited 15 seconds and second attempt successful. For next 3 hours, the engine had a rhythmic grinding sound which then stopped. Fuel tank had been filled the day before and was not near empty. Took to dealer, they have not been able to replicate event or find anything to fix. They replaced camshaft bolts because of a recall but reported nothing faulty with the originals. They are saying there is nothing wrong with the car. Do I take it back and risk the same thing happening or buy a new car? The car has 44,000 miles.


#2

Sounds like you still had electrical power. When you tried to start it, did the starter turn the engine? Fuel pump would be possibility. If the tank was full, the vacuum of the dropping fuel level could strain a weak pump. Was the grinding noise coming from the front or rear?


#3

Do I take it back and risk the same thing happening or buy a new car? The car has 44,000 miles.

When I get rich and famous I want to be like this. But I’d trade it in when it needed new tires.

Just teasing @Kaila;

If this happens again, I’d think Fuel pump too, or the crankshaft position sensor.
Also was there a “check engine light” on.

Yosemite