CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

2001 Chevy S-10 2.2L - Low Voltage (p0122 code) when Car has been Sitting in Cold Temps for Several Hours

Has anyone had this problem, just started this past Fall.

On very cold days (under 30-25 degrees F) when the car is started, idles high. When trying to drive it, car jerks a little when going into gear (i’m assuming because it’s idling high). When car comes up to temperature, it loose all acceleration. Car doesn’t stall, just loses all acceleration.

Even if I let the car warm up in the driveway, I get into the car push on the acceleration in park, car loses all power.

I turn the car off, then right back on, runs fine…no problem at all.

I’m getting an error code p0122 (Low voltage from Throttle Position Sensor). My mechanic replaced. After that I didn’t drive it much for a few weeks and also we’ve had a pretty mild winter here in Michigan so I don’t know if that fixed it and now its bad again OR if that was never the problem.

My mechanic looked at it again, said everything checks out. (I’ve been taking my car to this guy for the past 25 years and he has owned his own shop for at least 30 years so I trust him.)

Now he really didn’t look at the car when it was sitting outside when it was real cold for several hours, so I’m assuming that the reason he didn’t find anything.

I wouldn’t think there’s any wrong with the wires or having a bad ground, because this only happens when the car has been sitting for a long time, in fairly cold temps. I would think, if it were a wire or ground problem. It would do this anytime, no matter the temp.

Is the New Throttle Position Sensor something that could “become” defective after a short while from the car’s computer’s power source??

Could the computer be the issue??? Is that something that might be worth just replacing??? It looks like there only a couple hundred bucks online.

Has anyone else have this problem?? I haven’t found anyone on the web with the same problem.

Let me know your thoughts

Thanks!!!

The circuit is pretty simple

+5v reference (from ecm) … variable resistor sensor (signal tap back to computer) … ground.

So the problem lies somewhere along that path. The 5 v reference usually feeds other sensors, and since you aren’t getting complaints about other sensor having low output voltage, I doubt the problem is the ECM’s 5 volt reference circuit. If you are handy at debugging electronics stuff you could trace the circuit to see where it is failing. 5 volts from the ecm? 5 volts to the sensor? sensor tap measure in the 0.5 to 4.5 volt range and varies as you move the accel pedal? My guess is a problematic connection where the harness plugs into the sensor. Second up is where the harness plugs into the ecm. the sensor’s ground connection could also be the cause, but seems less likely than the prior ideas. The electrical connectors are plastic and contract more w/temperature than the sensor/ground hardware. It’s also possible the sensor/pedal interface is mis-adjusted or there’s a problem in the parts that hold the pedal bushings.

As you’ve discovered the car won’t run correctly with the tps signal not working. My guess is the replacement tps has now solved the problem.

Thanks for the info. I do appreciate it.

I’ll check it out.

Thanks again!