TPS signal voltage high AND low?

oldsmobile

#1

I’ve been messing around with an intermittent slight misfire/stumble/shudder on this car (90 Olds Delta 88, 3.8L V6) for a few months now. It would never turn on the CEL, so I had very little to go on. I changed the MAF sensor, idle air control and finally the throttle position sensor a few weeks ago. None of this fixed the problem. However, this morning the CEL finally came on for about 10 seconds, then turned off. It stored codes 21 AND 22, meaning that TPS signal voltage was both high and low. I think a TPS adjustment problem would only cause one or the other, not both (I did adjust it by the book when I replaced it, to ~0.40V with throttle closed). I’m thinking either defective new TPS, or a wiring problem. Any ideas? Thanks,



-Andrew L


#2

Usually the TPS is a potentiometer (3 prong variable resistor).
The wiper arm (center sliding contact) could make poor/intermittent contact and cause over & under.
Could also be in the connector to the TPS.


#3

After posting this, it dawned on me that one or both of these codes may have been stored a couple weeks ago, when I was adjusting the new TPS. Since the CEL was not on after I was finished with that, I never scanned for codes at that time. Of course, that doesn’t explain why the CEL came on today (just once, for that brief time, then no more for the rest of the day). I cleared the codes and I’ll see if one or both of them come back.


#4

I don’t think its the TPS. I would check the crank sensor, cam sensor, and the balancer pulley for starting to come apart. The TPS will cause a high or low idle but don’t think a shudder. I chased a problem with a miss on hard acceleration in my Riv. Replaced everything and turned out to be the balancer screwing up the signal to the crank sensor until it finally sheared it off and dead in the water. These are known or likely weak spots for this vintage.


#5

UPDATE:

Code 21 (TPS signal voltage HIGH) came back. Code 22 did NOT come back.

Let me describe the background of this problem a little. I’ve been chasing this for months (I like a challenge but this is getting frustrating!). There are several failure modes and I’m not 100% sure whether they’re all the same problem or not:

  1. After a cold start, if you immediately put the car in gear it will sputter unevenly for about 10 seconds. If you try to give it gas during this time, it will sometimes stall. It will stabilize by itself shortly.

  2. Under various conditions, the RPMs sem to fluctuate or momentarily drop. This can happen when idling, or during light-throttle acceleration and cruising. Heavy-throttle acceleration is OK (I figure this rules out a fuel pressure problem). Some examples of specific cases:

  • Cruising at a steady 45 MPH with light throttle, the car will start a rhythmic shudder: bump-bump-bump-bump. Giving it a little more gas, or letting off the gas completely, will stop the shaking.

  • Accelerating gradually through first gear from a stop, the car will buck or bump a few times before the 1-2 shift. This doesn’t feel like the classic “falls on its face” hesitation that you sometimes get in an old carbureted car. It’s just a series of quick RPM changes, as if I’m accelerating by “stepping” the gas pedal through a series of positions rather than depressing it smoothly.

  • Finally, one very specific case that has happened a number of times. I park the car in a bumpy alley behind my house. I’m making a lot of short trips in one day. I start the car up with the engine hot, pull out and slowly drive down the alley. By the time I get to the end of the alley, the RPMs will be in a fast rhythmic up-and-down sequence. Sometimes I can actually sit there stopped at the end of the alley, with my foot on the brake, and the engine will be going “vroom-vroom-vroom” as the idle bounces up and down.

Parts already replaced: MAF sensor, TPS, IAC valve. I also repaired a few damaged ground wires below the ignition module. I believe one of these is the MAF ground – not sure what the others are (I know none are TPS ground – TPS grounds at the ECM). Plugs, wires, O2 sensor are all a year old. Air filter is clean.

So that’s the back story. After code 21 came back today, I decided to check the wiring to the TPS. I unwrapped that entire section of harness, which includes the TPS, MAF, and 1-3-5 injectors. I fully unwrapped it all the way back to where it joins the big ECM harness behind the P/S pump. I cleaned all the wires and connectors with electrical cleaner and inspected everything. I found no evidence of a short or damaged wires. I have the Weatherpak terminal release tool, so I was able to completely take apart the TPS connector and clean it out. Everything seemed in good shape. I taped it all back up with a new plastic protective tube and put everything back together. I cleared the codes again and took a short test drive. The problem didn’t seem to be corrected (not surprisingly since I didn’t really fix anything) but code 21 has not come back yet. I imagine it will; it took awhile to come back the first time.

Any more ideas on this mystery?

-Andrew L


#6

Have you checked for a vacuum leak, which could cause symptoms like this?
That could also explain why the problem is not noticeable under hard acceleration as vacuum leak symptoms may be more noticeable at idle and light load operation as compared to heavy load operation where they may not be noticeable at all.

I’m a huge proponent of a vacuum gauge because they’re cheap, dirt simple to connect/use, and can clear a lot of questions up pretty quickly.
Just something for consideration anyway.


#7

I’m confused. You changed the TPS (Throttle Position Sensor) because you didn’t trust it. The new one shows the same code 21, and…What?
You visually checked the wiring, which revealed no visible physical damage. OK.
You need to check the TPS wiring with a multimeter. The gray wire carries 5 volts, constant. The dark blue wire carries the voltage varied by the TPS to the engine computer Sensor Signal input. This voltage will vary according to the throttle position, from 1 to 5 volts (or, from 5 to 1 volts). The black wire is ground, and is zero volts (as long as the engine computer keeps the sensor ground connected to chassis ground).
Connect the multimeter to the dark blue wire. S–l--o–w--l–y move the throttle from idle position to full throttle and monitor the voltage. The voltage should vary smoothly (and, go no higher than 5 volts).
Here are more instructions for checking the TPS, and other sensors: http://www.autozone.com/autozone/repairinfo/repairguide/repairGuideContent.jsp?chapterTitle=Electronic+Engine+Controls&partName=Driveability+%26+Emissions+Controls&pageId=0900c152800b1da6&subChapterTitle=Throttle+Position+Sensor&partId=0900c152800b1d06


#8

Vacuum leaks…I did some checking for that today. The vacuum system in this car is pretty simple (compared to the carbureted station wagons I used to drive). Most of the lines are hard (plastic or metal) with rubber connectors. I did some testing with a vacuum pump and couldn’t find a problem. I was suspicious of the line that leads to the HVAC and cruise, so I disconnected it, plugged that port at the intake, and ran the car that way, but it made no difference. So, I’m fairly confident it’s not a vacuum leak.

TPS…I think hellokit is right, next test will have to be an in-depth test of the TPS. I was able to do the adjustment when I replaced it, and I was getting the steady 0.40V signal with closed throttle, but I didn’t try monitoring the signal as I moved the throttle. My test setup was a little sketchy (just some spare wires wedged between the TPS connector and the terminals on the TPS) and I was having trouble getting it to stay together while I was testing. So, I may need to come up with something better.

By the way, no codes have come back after I cleared the 21 a few days ago, but the same driveability symptoms are still there.

-Andrew L


#9

Probably you can temporarily snake a vacuum line from the engine through the firewall into the cabin and put a vacuum gauge in a cup holder or something. That’ll allow you to watch the vacuum when the car is acting up. I did that once while chasing a problem a few decades ago and it worked OK.


#10

Your statements about the engine RPMS pulsing after you drive a bumpy road is interesting. This suggests to me a bad connection somewhere. Normally I don’t suspect the ECM at first for causes of trouble but in this case I may make an exception. Try tapping the ECM with a screwdriver handle while the engine is hot and running. You might also monitor the voltage output to the TPS when you do that. See if you can create any changes in the engine speed that way.


#11

NEW UPDATE:

I decided to check out the possibility of an ECM problem. I removed the panel that covers the ECM and noticed that it was not mounted in its bracket, it was just rattling around. I tried shaking it around with the car running, but I couldn’t cause anything noticeable to happen. I removed and reconnected all the cables and put the ECM back in the bracket tightly. So, nothing really solved there.

At that point, I hadn’t seen any new CODE 21s for a few days, so my attention started to turn away from the TPS. First I decided to check out the rest of the underhood wiring. I’ve been meaning to do this for awhile anyway, because there’s a lot of misrouted wiring and missing wire looms in this car from shoddy repairs in years past (I bought the car a year ago with only 65K miles, has 76K now). I pulled out the wiring for the ignition system (cam/crank/module) and cleaned that up, but found no shorts or anything. Put everything back where the GM book says it goes. But, still problem not solved.

Next I decided to take a look at the coil and module. Originally I was just going to take the coil off and see if there was any water damage or corrosion or something that might indicate a problem. Well, the first two coil-to-module screws broke off in the module! What’s that saying – “if it breaks, it needed replacing anyway?” I stopped there, went to Pep Boys and bought a new coil and module. On the way home, the CEL came on…CODE 21 again…more on that later. Here’s the weird part about the coil: When I finished taking the old coil off (broke 3 of 6 screws) the gap between the coil and module was full of bubbly, green goo – it looked like something out of “Ghostbusters”! There was nothing like that in the new coil or module. Anyway, I swapped on the new coil and module, but no real improvement.

Since code 21 had come back in the meantime, I decided to refocus on the TPS. I came up with a sturdier test-lead setup that would allow me to move the throttle while the multimeter was hooked up to the TPS wiring and watch what was going on. The TPS on the car (this is the NEW TPS because I had already replaced it weeks ago) seemed to perform OK on this test. The voltage changed gradually as I moved the throttle, and always returned to around 0.40V when the throttle closed. But, after I cleared the codes again, 21 came back almost immediately.

So now I’m thinking, if the TPS is good and the wiring is good but the ECM keeps complaining of high voltage…maybe the ECM is bad? But I wanted to try one more thing first. I still had the old (original) TPS. I cleaned it up with contact cleaner and swapped it back in. It also passed the multimeter tests OK. I cleared the codes again and drove around for over an hour – still same symptoms, but code 21 did not come back.

At this point, I’m going to leave the old TPS in and keep driving and see if 21 ever comes back. If it doesn’t, I’m thinking the new Autozone TPS was defective and intermittently shorting out. I never had a code 21 (or any code for that matter) until I put that new TPS in – I just bought it on a whim because I couldn’t figure out what was wrong. If the new TPS was defective, I may have just stacked a second problem on top of the first one…whatever it is.

-Andrew L