Suburu key fob stopped working and its not the battery

My original key fob and key were stolen to my 2003 Impreza Outback Sport. I pulled the ignition fuse until I could retrieve the spare fob, dug out the spare key and fob, put a freshly bought battery in, replaced the ignition fuse.

Car starts and doors unlock manually with spare key but the fob does not unlock the doors or make a sound but a little red light lights up on the fob.

Did I disable the fob somehow by pulling the ignition fuse? My original key fob worked fine before it was stolen, and the spare fob worked fine last year so…

Please help -

Twenty years ago while at a manufactures training center I was told that a rolling code transmitter could become out of sync with the vehicle’s receiver if someone pushed one of the buttons more than 200 times while out of range of the vehicle, I have never seen this occur myself. Perhaps your transmitter became out of sync because it has not been used for so many years.

You might have the transmitter registered again (may not work) or buy two new transmitters and have them registered.

Hmmm - thank you for the tip. It’s been about 4 years since using the spare fob. I googled how to register a key fob and it returned results for programming a key fob. I’ll try that. Thank you.

Helps to have the manual. The answer is in the manual for anyone who experiences this. Once I found the manual (also helps to keep it int he car glove) discovered that battery changes prompt a reset of fob by hitting arm/disarm six times in a roow.

As is the answer to a lot of questions people have about their vehicles.