Electrical problem

cavalier
chevrolet

#1

I have a 1999 Cavalier with an electrical problem. With the car off, I can normally press the top knob (on/off/volume knob) on the radio and the clock shows the time. Now that doesn’t work, and when I turn the ignition on, the clock shows 12:00 and my preset stations are gone. The clock works normally as long as the car is on. Also, the interior light doesn’t work at all. Opening doors, dimmer switch, car on or off, none of that makes a difference.



With the car off, the lighter and headlights work. And the OBD monitors are ready, so some things are getting power.



It’s possible the interior light is simply burned out, but it’s strange that the problem started exactly when the problem with the clock started. I checked the related fuses in the main fuse block, and all of the large underhood fuses. They all look good. It doesn’t seem like a fuse problem, but I didn’t know of anything else to do. Currently, it’s only a minor inconvenience, but I want to know why it’s happening in case it’s a problem that might spread or indicate deeper problems.



To summarize, the clock gets power only when the ignition is turned on, and the interior light doesn’t work at all. Any suggestions?


#2

I don’t know if it’s important, but the clock and radio work normally (although the clock starts at 12:00) with the key in the accessory position, as well as the run position.


#3

Check your fuses. I suspect the feed to the stereo that supplies the ‘keep alive’ power for the memory is dead. It’s probably the same circuit as the interior light.


#4

This seems to be on the right track. The owner’s manual says the “INT LAMP” fuse powers, among other things, the radio. There’s a main radio fuse, so it makes sense that this one is always-on keep alive power.

The fuse looks good. I switched the interior lamp fuse with the radio fuse (both 10 amps) and the radio still works and light still doesn’t, and the clock still doesn’t with the ignition off.

Given this information, it seems to be an “INT LAMP” circuit problem other than a fuse. This may be related to the “convenience center” that I once took off when looking for another electrical problem. I plugged it back in, but never properly secured it. It’s a pain to get at the screw, so I just left it hanging. Tomorrow in the daylight I’ll see if anything’s unplugged.


#5

Being impatient, I looked with my 12-volt light, and found the unplugged connector on the convenience center. Plugged it in, and problem solved.

This happened on one of the rare occasions when I had a passenger. He must have kicked it (because it’s somewhere it isn’t supposed to be), and made the connector come out.

Thanks for the hint; it pushed me in the right direction.