Problem with Fuel Gauge

2003 Dodge Caravan SE, 106K miles. Just replaced the fuel pump with a part I got at carparts dot com. Something strange going on with the fuel gauge.

  • It’s reading Full, even when the tank is half empty. (I added 12 gal to the tank after it was reading full, and it’s a 20 gal tank, so the tank was actually less than half empty.)

  • When I turn off the engine, the gauge drops to 3/8 of a tank for a moment; then goes to 1/4 tank and stays there. (It previously always went to Empty when I turned the engine off.)

  • I ran an Instrument Cluster Self-Test. After doing that, the gauge went down to Empty. However, when I turned the engine on, and then off again, it went back to being stuck at 1/4 tank.

  • The car seems to be running fine. No problem starting; no hesitation. Fuel seems to be being delivered properly.

Here’s a video that shows the gauge malfunction: Dropbox - gauge malfunction.mp4 - Simplify your life

And here’s another video that shows that Instrument Cluster Self-Test, and how the gauge goes back to E afterwards: Dropbox - instrument cluster self test.mp4 - Simplify your life

Any thoughts on what it might be?


1 Like

Ideas are free of charge. Sort of like a dead battery. The tank unit is new and tight and it is sticking. When it gets some wear on it, the thing will work better. That would be a miracle but things work out in my alternate reality.

If it came vrom, it isn’t new it is used. That is the luck of the draw on a used part.

The float arm was likley bent when the pump was removed from the donor’s tank or it is corroded. It might loosen up but it won’t bend itself back.

You might pull it out and give it a good look to see if you can fix it.

Either live with it an hope it clears up or buy a new pump assembly.


Or the problem might be that while the fuel pump itself is fully functional in your vehicle, the other part of the pump assy – the fuel gauge sender — is designed for a different vehicle. The sender’s float moves up & down with the tank’s fuel level, and that motion changes the resistance of a resistor. The dashboard fuel gauge is really just a resistance gauge, like when you measure resistance with an ohm-meter, but the fuel gauge is calibrated to the expected resistance range. Your shop could measure the resistance with the fuel at a known level and see if it matches the expected resistance, obtained from the car’s specifications. That’s probably where I’d start. It might be the resistance matches the spec, then you’d know the problem was the gauge itself, or more likely some problem in the electrical connection between the gauge and the sender. Cross your fingers.

@Mustangman: can you elaborate on that it isn’t new, it is used, if it came from carparts dot com? Obviously they advertise the parts as new. Can you elaborate on how you know they actually sell used parts? Thanks!

@George_San_Jose1 You seem to agree with Mustangman that it is actually a used part, since you say the pump assembly is designed for a different vehicle. As I asked him, just curious how you know they sell used parts?

And I texted the service manager of the shop that installed it. He replied:

the float is probably above the line in the tank instead of below. Somewhat common normally a very quick fix

So hopefully it’s something that simple!

@Mustangman Ah, wait a minute! You wrote I thought that was just an alternate spelling. No, I didn’t get it from Yes, sells used parts. I got it from They claim to sell new parts, not used. That’s why I was troubled by and curious about your reply that it was actually a used part.

Here a link to the part itself. If you click under “See all product details” it says the part is new. The company also has an A+ rating with the BBB. So, yeah, different company. :slightly_smiling_face:

Ok, new part but really cheap new part likely made in China. That might be your problem.

The last pump assembly I bought was $200.

1 Like

When you know the gas tank is low, take a rubber mallet and give the bottom of the gas tank several good whacks to see if that fixes the fuel gauge.


I guess pumps for different cars cost different amounts. The shop was going to charge me $129. Autozone had the part for $85. So, yeah, probably a cheap new part.

@tester: Interesting thought! Thanks, I’ll keep that in mind.

Such a thing is possible, but you’d think the shop would notice that the arm was sticking before installing it in the fuel tank. Me, I’ve have my ohm meter out and measuring the sensor’s resistance along the entire float arm range on the work bench, & making sure it moves freely, before installing it… hmmm … Maybe the float arm is being interfered with by something inside the tank, so it rotates freely when outside the tank, but it too close to the side of the tank maybe. Just needs to be bent a little. Crossing fingers.

Yeah, I guess we’ll see. Dropping it off tonight. Hopefully they’ll look at it tomorrow.

They pulled the fuel tank down to repair a vapor leak, and were supposed to replace the fuel pump at the same time, but forgot. So they had to drop the tank a second time to replace the fuel pump. So maybe they were rushed when they did it. I don’t know. I guess we’ll see.

Here’s an update to the situation.

It’s been at the mechanics for a couple of days. They removed the fuel tank and tested the fuel pump and said it’s working fine to send the appropriate voltages.

They believe it’s a gauge cluster issue because even with zero volts going to the gauge, it still won’t go below 1/4 tank. Even with the fuel pump completely removed, the gauge won’t go below 1/4 tank. They brought in another fuel pump from AutoZone and it did the same thing.

The only problems with this analysis are:

  • The gauge was working fine before they replaced the fuel pump.
  • It wasn’t just that the gauge won’t go below 1/4 tank. It’s also that it was showing full when the tank was actually 3/8 full.
  • I ran the cluster self-test, and the gauge passed the test and went all the way to E after the test was done. It was only after starting the car again after doing the test that it would get stuck at 1/4 tank.


hmm … well, maybe the gauge problem was about to happen anyway, unrelated to fuel pump replacement. Possible, but would be a very big coincidence. Do you still have the old fuel pump and sender ass’y? If so, you could measure the sender’s resistance on the work-bench at the full and empty float arm positions. Might provide a clue.

No, don’t have the old pump. But I found this online just now:

“So one issue that I’ve had w/ my R50 is that the fuel gauge works fine until 1/4 tank and then it won’t go any lower (except when the car is off… so I know there’s no physical obstruction in the cluster). I ran out of fuel on my way home when I bought it, b/c I didn’t know how to cycle through the OBC yet, and thought I had 1/4 tank left. I’m going to try an ECU reset, but I don’t think that will help. Do you guys think there might be an obstruction around the float not letting it drop further than 1/4 tank? How would I check for that?”

Then, later:

“So… ECU reset SEEMS to have cured it. I went through the diag menus, and have 2 good sending units. After the reset, the red light indicating < 2.5 gal fuel was illuminated for the first time since I’ve bought the car. As an added bonus, my trip to the fuel station also gave me my first >30 mpg reading on the OBC. Maybe I’ve gained a couple MPG in the process too!!”

So I called them with this. The mechanic is about to leave. So they’re going to unhook the battery cables and leave it overnight and then see in the morning what it does.

1 Like

Didn’t they disconnect the battery before replacing the fuel pump? It seems like that would have already reset the computer.

1 Like

Yeah, they did disconnect the battery. But it’s possible that something happened to throw the ECU off when they reconnected the battery or whatever.

In any case, I talked to the service manager again, this time after he spoke to the mechanic.

The mechanic told him that when they had the problem with the gauge cluster, the first thing he tried was disconnecting the battery to reset the ECU because, he says, those older dodges have that problem a lot. It didn’t resolve it.

He said he also tried applying a direct ground to the wire that receives input from the pump, which should have caused the gauge to go to E, but it didn’t.

So he’s 100% convinced the gauge cluster is bad, even though it was working fine before. I don’t know if maybe there was some electrical charge that damaged it during the repair?

Anyway, at this point, they’re going to try and order a new gauge cluster and see if it fixes the problem. They’ll have to get a used one, so they don’t know how long it’ll take to find one. But in the meantime, they put my car back together, so at least I’ll be able to use it. Then, when the new gauge cluster comes in, I guess we’ll see if that resolves the problem.

Check if the ground strap on the gas tank got plugged back in when the tank was reinstalled.

Item 4.

Sometimes these yanked off without knowing it when the tank is removed.


1 Like

But if he applied a direct ground to the gauge cluster and it still didn’t go to E, wouldn’t that indicate that it’s not related to the fuel tank?