Cigarette lighter won’t work

honda
odyssey

#1

Cigarette lighter won’t work ‘14 Honda Odyssey. Changed fuse- worked for 15 minutes. Changed again- won’t work at all. Any thoughts as to why?


#2

Did the car originally come with a cigarette lighter? Most cars now have an “accessory plug” and many, including both mine do not fit a cigarette lighter. Cigarette lighters draw a heavy current and those modern plugs may not be able to handle that.

I would go back to my owner’s manual first.


#3

What are you plugging into the socket? Have you tried a different item? Have you looked inside the socket for debris and cleaned it out?


#4

FDA regs have made cars non-smoking.


#5

I suspect that you have a short that is blowing the fuse.

Check that all the other accessory plugs in the vehicle are clean and free of any foreign objects.
Kids love to put items in them.

Yosemite


#6

My 2010 Kia has no lighter or ash tray. There are 2 sockets for charging cell phones and electronic devices such as tablets. I had no idea it was FDA mandated but don’t doubt it. Tobacco use may result in a slow personal death. Use of cell phones and other devices while driving may result in instant death or serious personal injury. And the same to innocent passengers, drivers, cyclists, and pedestrians. Which is worse?


#7

I called it a cigarette lighter, but it is an accessory outlet. Nothing is in it- blew compressed air in it. Changed fuse, it worked for 15 minutes- charging my iPhone, then quit working again. Changed fuse- now will not work. Other accessory outlet in back works. Other things work surrounding it on the console. Very frustrating!


#8

I must have replace over 100 power outlet fuses for frustrated customers and the cause of the blown fuse in each case was the device that they plugged into the power outlet. How often does a circuit breaker trip in your house when nothing is plugged in to that specific outlet?


#9

I wrote that ironically.

Are they on the same fuse? Maybe the outlet is broken. Spray it with contact cleaner and scrub with an old toothbrush.


#10

This has happened to me, too. There’s a brief short circuit while the device is being pushed into the socket. Some plugs do this more than others.

The fact that your device is now not working even after replacing the fuse is further evidence the problem is in the device you are plugging in - most likely its plug.