CarTalk.com Best of Deals Car Reviews Repair Shops Cars A-Z Radio Show

2002 Chevy Impala won't start

I have a 2002 Chevy Impalah 100k miles that frequently won’t start. When I put the key in the ignition, I get lights, radio, and all electrical signs. But no sound from the engine. No matter how many times I try to turn the ignition, I get nothing. But then when I stop trying and then come back to the car 5 to 10 minutes later, the car will start with no problem. This seems to happen randomly–sometimes first thing in the morning, sometimes after being parked for an hour. I can go for days with no problems and then it will start happening (randomly) again.

I just brought the car back from a dealership–they couldn’t reproduce the problem and can’t find anything wrong with the car. Has anyone else had this problem, or can someone suggest what systems or parts might be malfunctioning?

There are 3 things that jump out, first how old is the battery? if older than 4 years a battery and coincidental connections are suspect 1. Suspect 2 bad ground connection, suspect 3 bad ignition switch.

Add to the list of suspects and intermittent problem with GMs idiotic Passlock security system.

I second the Passlock suggestion. It can be pretty trouble ridden.

Third the pass code, it’s the first thing that came to mind. Does the dash say security while trying to start?? One more thing you can try next time it acts up is to put the car in neutral and see if that helps.

The “02” had the ignition in the dash if I’m not mistaken, and I have seen several of these display the same symptoms you are describing.

Try the ignition switch mine did the same in my 1998 maxima