CarTalk.com Best of Deals Car Reviews Repair Shops Cars A-Z Radio Show

2001 VW Beetle 2.0 - EPC, Check Eng. & Temp Lights

Hello: Just like my title - My VW Beetle is a 2001 2.0. I haven’t had it long. I can not really say how it behaved in the past. (I have replaced the timing belt, water pump, tires, rear lights…& some other misc. parts) Anyways, so, I can not find a correlation between this or that when it comes to this problem. – When I start the car (totally random when it does this) it will idle between 800-300 aprox. The “EPC” and “Check Engine” lights are on almost all the time; the temp light goes blue or red at random. If I try to drive it, I can put the pedal to the floor and I get nothing. I have to turn the car off and restart it to get any kind of change. Sometimes, I have to restart it a few times before it stops. This happens when the car has been sitting or running for a while…I don’t know what the problem is. My mechanic looked at it and ran diagnostics, they got like 30 codes…Neither I or my trusty mechanic can decifer what this is. The best description I can give is that it is almost like I am trying to go in 3rd instead of 1st gear. It is a 5spd manual by the way. Anything, anyone can offer would be great. If you need any more info I will be happy to provide…this has been going on for about 60 days.

 That CEL (check engine light) is just a kid in class waving her hand trying to get you attention because she has the answer. You need to have the codes read. Some places will read them for FREE. Try Autozone or Advanced Auto Parts. Get the exact code (like P0123) not just their translation into English and post it back here.

Well, having like 30 codes should give your mechanic plenty of places to start looking. Why can’t he or she decipher the codes?

Yeah, I had another car where the CEL was constantly on. I had almost everything possible checked or replaced. It was on until I got rid of the thing. I had the codes read by my mechanic. My mechanic didn’t have the proper software for the car and referred me to the dealership…I will post the codes when I get home. He also reset the computer and the EPC came on shortly after driving the car.

I do not believe my mechanic had the proper software for the car’s computer. (check out my other response above) He referred me to the dealership. After reading several posts online about this similar issue I would like to get some opinions from fourums such as this one. It appears that several people are having a similar issue.