CarTalk.com Best of Deals Car Reviews Repair Shops Cars A-Z Radio Show

07 Murano acceleration issue

I have an 07 murano SL AWD. Recently replaced all 4 brakes, along with the front left wheel speed sensor because the tip of the old sensor was broken off somehow.

My current issue is that shortly after driving, within a mile from start… My Murano will go into what I can only guess is “limp mode”, the rpm’s bounce a little between 1000-2500 rpm’s once the engine goes into limp mode… and also my “slip” light flashes on and off as if I’m driving on wet road or ice and sliding. The car will not go past 40 mph at all, even when I punch it a little more to try. Day or night it does not matter I cannot move past 40 mph… nor can I keep a steady speed like 25 for more than 1/4 a mile without the engine doing the limp mode and slip light flashing…

No engine light on, nor abs, awd, vdc… nothing.

Could this be a defective wheel sensor? Even with the prior sensor I never experienced this issue, just the normal abs, awd, and vdc light on due it being broken.

Please help.

Your Murano has a drive-by-wire throttle system.

Instead of having a throttle cable between the throttle pedal and the throttle body, your vehicle has a throttle pedal position sensor which sends a signal the computer, and the computer takes that information and operates the electronic throttle body.

That’s where I think the problem lies.

Tester

1 Like

I can follow and understand what you are saying.

Regarding the throttle body, I recently took it off and unplugged it to clean it with carb cleaner because the build up was fairly intense. Clean as a whistle now and did the idle relearn successfully earlier this evening.

But you are saying the the throttle position sensor might be faulty? How do I go about checking that (assuming I can ).

Lastly, would you think that’s causing my car to go into limp mode?

You may have to take your vehicle into the dealer, and have a throttle body re-learn performed.

Electronic throttle bodies aren’t something to mess with unless you know what you’re doing.

Did you know that if you open an electronic throttle body by hand to clean it, it may require a reprogram of the computer to get it to work right again?

Tester

I understand the relearn and throttle body systems. The idle relearn was successful… in fact it runs amazingly and idles better now.

I do know I’ll most likely have to bring it in…was just trying to get a better understanding as to what is wrong so I don’t get screwed with them telling me I need a new freaking trans or something… you know?

If one of the wheel speed signals is out of sync due to a malfunctioning wheel speed sensors or a mismatched tire size the stability control can disable the throttle control until the vehicle is determine to be under control. A scan tool capable of communicating with the Vehicle Dynamic System module will be needed to monitor the wheel speed sensors to diagnose the problem.

Try switching off the VDC (Vehicle Dynamic Control) and see if the vehicle can be driven without interference from the VDC system.

Watch this.

Tester

I actually watched that video earlier tonight lol, I had my girlfriend sit in the car and operate the accelerator to open the TB for me while I cleaned it.

The problem has been happening for a few days now and I did the TB this evening… the car initially accelerates better and idles more smoother and lower rpms to normal than before (was a tad high around 1200 rpm’s)… now idles at roughly 700.

But the problem has been very persistent and constant under the same factors every time… I drive out of my driveway, everything is fine, and whether or not I hit 40 mph, the slip light comes on and my engine buckles slightly like it’s downshifting and I cannot go any faster what so ever… even at a constant 20 mph it does the same thing after roughly a quarter mile. (I tried the lower speed to see if it was simply not going into higher gears).

I also researched the other day about the wheel speed sensor and also read about turning that vdc off. I tried it and it still went limp same as it has been.

Sounds fixed. Why would you now have to bring it in?
Or did I miss somethin?

Because this problem was happening before I touched the TB and despite cleaning it and everything (as I was somehow hoping that was the issue and have been wanted it cleaned for a while now) my car still goes into limp mode within a quarter mile of initial driving no matter the speed, but always cuts off at top speed of 40 mph. It Boggs down like it’s applying the brakes or something and accelerator is unresponsive… unless I bring to under 10 mph or complete stop the vehicle won’t accelerate.

I’m just trying to get some help understanding what’s going on here :sob: or an idea of what I should specifically look at or have checked out.

Thank you guys so much thus far for responding so fast!

You said in the very first message:

Why don’t you concentrate on this first, as @Nevada_545 suggested?

So, what can go wrong?

  • sensor was damaged, this is a fact
  • it was replaced, this is a fact
  • Q1: now, can you be sure replacement one did not break the tip from the piece of old one stuck next to hub?
  • Q2: are you sure that the sensor installed is a right kind? new? not damaged anyhow?
  • Q3: are you sure sensor connection was made tight?
  • Q4: are you sure sensor connector was not anyhow damaged when removing old sensor?
  • Q5: what about tracking entire connection chain down to the control module?

you might find nissanhelp.com site of some help looking for factory service manual for your Murrano, as well as asking for advice there, the guy moderating forums there is former Nissan tech and is very knowledgeable

1 Like

Possibly the engine computer is confused b/c it is measuring the wheels rotating at different speeds b/c of a faulty sensor, and doesn’t know how to interpret that. So in response it refuses to go over 40 mph, for safety concerns. The thing that is inconsistent with this scenario is that the check engine light or at least the abs/stability lights should turn on the dashboard warnings. Double check that those light up with the key in “on” but the engine not started, to verify the bulbs are indeed working. If the bulbs are working but not turning on w/this symptom, probably unrelated to the wheel speed sensor, and best to focus on the throttle-by-wire issues.