06 Acura TL U0107


#1

Hey guys I’m trying to figure what’s going on with my car I drove it fine home then when I turned it off and tried to immediately afterwards adjust the parking the car wouldn’t turn on with the clutch engaged. Tried several times to turn the engine then gave up. Next day I adjusted the pedal and pushed the pedal all the way to the floor and it came on.

But now I have the issue of the check engine light being on And VSA light checked the code and it says U0107 and the car won’t go above 2000rpm. We tried changing the app sensor and it worked for a split second then went back to the code. Checked the battery voltage and battery is good. I then changed the throttle control relay under the glove box and still nothing.

I’m stumped what am I missing here?


#2

U0107 = no communication with throttle actuator


#3

Yeah I’ve got the same message come up every google result everyone always results to the methods I just did but they never leave feed back on the results. Trying to avoid buying expensive parts for no reason if it’s something simple that I’m overlooking


#4

An rpm of 2000 means your in limp mode. Apparently the ac drain line gets clogged and corrodes the relay and or its contacts. The relay is behind the glove box. I would also reseat the throttle actuator module connector. http://m.honda-tech.com/showthread.php?t=3168932&styleid=18


#5

I changed those relays still get the issue. Are you familiar where the throttle actuator module is?