'02 Mazda Tribute Cranks but no start, no fuel pressure or fuel pump will operate

Was idling to warm it up and after 5 min it stalled…this was 8 days ago and I’ve been at it everyday going through every possible scenario. I can start it ONLY by using starter fluid and it dies immediately after that has been used up. Inertia isn’t tripped. Relay and fuse to the pump are good and fuel filter is new as i went ahead and replaced items one at a time to help eliminate but to no avail. (Crank and camshaft sensors, idle control valve) The only weird thing I’ve noticed is a low buzzing sound when the key is in the “on” position that is intensified only when I slightly jiggle the throttle with my left hand as I listen with a stethoscope in my right hand and it is the loudest at the transmission but can be heard all over…UNTIL…I unplug the EEC Relay. Then the buzz is completely gone. I have replaced 3 relays now and they just keep getting fried after I leave the key on and listen around to better isolate the buzzing sound or try and start it after trying something else only to still be no further along than what I have explained here. Please help if you can… I cant afford to do anything other than get what I need at the junkyard and make it work by doing it myself. I’ve been sorely disappointed in the past several times at multiple Mechanic shops and only end up poorer and sometimes with even more issues!!!
I grabbed another ECM from the junkyard thats an exact match but dont have any way to update it to my original keys so i cant even test it yet. Is this just a bad ground inside somewhere I’m not able to see? My original ECM looks very good on the inside and the motherboard, soldering, chips, pretty much everything looks like it should and doesnt indicate its bad by looks or smell. Ive notived the transmission would almost ALWAYS hard shift in to 4th and only the 4th gear. It has stalled while driving a handful of times over the last 2 years. All maintenance is kept up on it and is a Very well taken care of vehicle. Slow drivers mostly and rarely need to get in to the pedal. Any insight would greatly be appreciated :relaxed::+1:

Did you replace the fuel pump? Fuel pumps fail much more often than fuses and relays.


I’ve seen people work on their cars for a month and put several hundred dollars of parts into trying to fix them, only to find out they were out of gas, even though the gauge said 1/2 tank.


Hi yes i replaced with 2 more fuel pumps and eventually tested the original since it is only 3 years old and found it to be properly working when bench tested as well as ohm and continuity tested. Was Not the fuel pump as i originally thought since its the first places to go to when something like this happens. No fuel pressure even though the pump and filter are still very good

I have over a third of a tank which i visually checked since I tried 2 fuel pumps when it all occurred since thats what is usually the issue that causes these kinds of symptoms. Got gas, good pump and new filter with all working relays but the EEC relay is involved someway with a humming sound and after a few minutes of listening trying to trace everywhere to try to isolate the hum i have to replace the relay since its also involved with the fuel pressure system. I dont know if this is a bad sensor or bad ground or something else…

What else can shut down the fuel system to prevent it from activating? Any thoughts?

Is the fuel pump getting power and ground to the pump wire connection at the pump?

If the wires are damaged, or the hot lead is shorted to ground somewhere from the relay to the pump, it would fry the relay. The buzz could be the sound of the short.

1 Like

Thanks for your suggestion… I’m actually looking in to that right now. Will update as soon as i determine if power and ground is present.

does this mean you replaced the EEC relay too?

Yes. Checking power with test light at pump and other locations now to see if i can find the cause for the no fuel pressure

I had a Miata ECU tested and repaired by a vendor in FL I found on ebay. They claim to give a free diagnosis if the unit is good, and repaired it for about $120. They claim “plug-and-play” with a repaired and re-programmed unit. They lived up to all promises. I understood that the fuel pump ground is established by the ECU, and the lack of ground indicated a failure of the ECU.

Thank you for that info. Im really leaning toward the ECM as the cause… I have to call a locksmith who is capable of reprogramming the keys but have been holding off just in case i find a different issue that fixes this craziness :grimacing:

I just recorded a video with my phone showing the buzzing sound as i jiggle the throttle and it is easily heard on the video but it xant be uploaded ad a file from my phone and must be converted to be accessible to this site. Ill try to figure out how to do it.

Check the fuel pump ground, or even jump it to a known ground and make sure the fuel pump is running.

1 Like

Just tried testing the connector at the fuel pump and the positive is 9.3 and ground is 0.01

Tested my battery just to see and its 17.1 volts! This cant be good…

I did jump fuel pump and it is still very much alive and working. The prime is not and im stuck at the fact the computer is not activating the fuel prime and pump. Im about to start removing one item at a time on top to try and access the wire harness and check all connections and wires. I want to tey and rule out everything before i have to call a locksmith to come to me and reprogram the ECM I picked up from the junkyard to work with my keys.

Did you check the battery with the engine running? I don’t see how you got 17 volts!

I had been charging it and was testing it immediately after i disconnected the charger

I still cant start it unless i spray starting fluid