Wiper don't work, fuse brakes

Hi, i had recently a overload due a defective alternator on my nissan. Everything went out.

Since then the wipers don’t work.

My mechanic told me that the wiper motor had a a short and needs to be replaced, but for $300 Dollars. All the shorts are supposedly removed.

So now i did it myself and bought one from autozone and replaced it. But still the fuse goes out.

I suspect the switch, which seems to be on the driver side. The manual doesn’t mention it.

Does anyone have an idea if my guess is right?

Its a Nissan Altima 2001. Got to get my volt meter going since i could not verify this. So i don’t know if my motor is really broken or not.


I doubt the trouble is with the switch. The power lead needs to make a connection to ground for a short to occur. I assume that the fuse blows out only when you turn on the wipers. Disconnect the motor and see if the fuse still blows out then. If it does you need to check for a short on the power lead to the wiper motor.

I will try this out. Would i need to rewire if it did? Might be something i can’t do myself. Mm…

You may be right. I did as you told, and no short. So it seems that it is the motor. Funny thing is, that it happens with a new motor.

Make sure that the wiper mechanism is not jammed. If the motor can’t turn it will cause an overload on the circuit. It would be a real slim chance that the new motor causes the same trouble as the old one does. If the wiper mechanism is ok then there may be something else in the circuit after the motor, like the delay module, that is causing the trouble.

would that be a relay? I was looking for it, but it seems that my nissan does not have one.
For one, if the fuse stays ok with disconnected motor, then the cable is ok.
I can’t solve it today or tomorrow anyway. Good thing it does rain in socal that often.
anyway happy holiday.

I will check if there is play for the mechanics. Need to buy also more fuses. I went through 5 already.

The delay module is an electronic module, not a relay. Since there is no short with the motor removed then the switch wiring is most likely ok. The trouble is most likely with the delay module if the wipers are free to move.

It seems that i have no relay in my car for the wiper. At least i wasn’t able to find it.
In my version of the car i only have one cluster of relays in the engine room. There are some under the driver side but don’t relate to it it seems. The Haynes guide insist on a relay though.
You mean the switch on the wheel i assume. Got to check that still.
Googling on the web did not surface anything useful to this problem either. Can you check the motor without power with the voltmeter? I just want to make sure that my original motor is either really broken or not.
I wished i was more of an electrician really.

Most vehicles don’t use a relay for the wiper circuit since the motor current draw is fairly low but your vehicle may have one. Even so it is very rare for a relay to have a short to ground so the trouble isn’t with it most likely. If you do find it you could try swapping it with another one similar to it to verify it. I don’t think the trouble is with the wiring to the switch since you have no trouble when you disconnect the motor. I’m pretty certain your vehicle has a delay module most likely located under the dash somewhere and suspect it is causing the trouble.

From the diagram it shows a relay and a time control unit. The latter i wasn’t able to locate so far.

Ok, a little more.
I tried to check the motor with a volt meter. I switched to milliampers and checked the flow. It appears that i get from the motor plus readings about 0.02 on either pin. If i check the electric i get negativ readings about 0.02 and one pin giving me 0.25.
Now i think that the fuse will go out because of opposite electric flow. I will later take off the bezel from the steering and test the wiper switch.
I don’t seems to find the time control. But under the driverside in the fuse box is a relay shaped unit with caples attached. I don’t have a description to it and the haynes manual does not give me anything either on that.
Where would i find the delay module or is the same as the time control unit?

Also, there is another not related problem. There is a fuse (10amp) which is for indoor light which is blown. If i put a fuse in, all lights on the dashboard go on. What doesn’t work is the car alarm and the trunk remote opener.
I dont think it is related to the first issue, or maybe it is. Not sure.

I think the time delay device you see is a circuit breaker. They usually use them in the wiper circuits in case there is an overload on the circuit. After some time they reset so you will be able to use the wipers after the trouble on the circuit has been cleared. It’s a safety issue. Thinking about that now makes me wonder why there is a normal fuse in the circuit that is blowing out.

I’m not sure why you are trying to check the current through the motor. You have a new motor so you know that should not be any problem. Also, are you aware that current readings need to be taken with the meter probes placed in series with the circuit power? If you want to check for power use the voltmeter function to check the voltage getting to the circuit.

As far as the other blown fuse goes I assume a replacement works ok for that area and the other issues you have are a seperate problem.

Well, i was hoping that the mechanic was wrong and that the old pump is still ok. The breaker, yes. I know where that is and indeed, according to haynes, it should reset after some time.
I will check that also tomorrow.
Since i am not an electrician, i try to engage with some logic to it.
Something causes the fuse to break and now, with a new motor in place with the same results i am not sure if it broken. Will see tomorrow.

It is very doubtful that you purchased a new part that has the same problem as the old one. Something else in the circuit is causing the overload, unless the wipers are jammed. Your service manual should show you all the wiring for the circuit. I’m pretty sure there is a delay module for the wipers in the circuit and suspect the trouble is with it.

I think i am almost ready to declare defeat.
I rechecked the mechanics on the wiper, but they are fine. Not to tight and moves fine. I losend it a little.
The funny thing is, the wiper even moved a litte. But then the fuse went out again. I checked my wiper switch and it seems fine. I followed the haynes manual on this.
The breakers i took out and switched them with each other, but did not change the situation. There are even more relays behind, but i have no information on them.
Seems like i need to bring it to a mechanic.

Its solved.
Neither part was faulty. The only thing that was broken was the relay which was at the passenger side around the right foot area.
I got a replacement from the junkyard and it worked again. The repairshop was lying, since they insisted that it is the motor. My old motor just works fine and so does the switch.
I was able to return the unused components.

Feels good to solve your own problems :slight_smile: especially when you prove the mechanic wrong and save yourself a bundle. Nice going, yester64

Well, i will tell you.
I had to relay on a friend who is mechanic. He did troubleshot it for me since i was unable to pin point the cause.
Originally i got an problem presented ‘your motor needs to be replaced’ for $300 Dollars. Now i tought, ok i can do that myself. And then i bought the motor and replaced it in the hope that was the problem.
It wasn’t. The fuse shorted out right away once the there was a complete circuit. Then i thought, ok maybe its the switch too. Bought that too. Did not solve the problem.
The Haynes book was no help either. It showed a diagram of fuse, motor, switch, relay and the TCU. Problem was, there was no indication of where the relay actually is. They did however showed a picture of relaybox in the engine room which had a relay there.
But in my car this wasn’t the case.
Finally, my friend mechanic solved it by checking all the wires and components. Locating was done by listing where the click from the relay was coming from.
It is a black box, meaning it looks different than the regular relay in the car. Since i knew what it was, i just needed to go to the junkyard and get it from there. My assumption was that it will be more expensive if i get it from Nissan. Special parts.
In the end, the repair was 25$. The labor i spend (mostly my time) not counted.
It just drive me nuts to have mostly changed all, but still not able to fix it.
Not sure how to judge the repairshop. They did some good work on the car, but this proved to be bogus. Some other dude would’ve paid the 300$ and all they did was change the relay.
Still thanks to Cougar for giving me ideas.