Odd fuelpump power


#1

i have a 99 tahoe with a 350 engine. one night i went to start it and heard a loud noise then smelled an electrical burn smell.

after this the truck will not run. after talking to a gm mechanic i replaced the ignition components on the collumn . after reading some of the info on this site i realized i had triggered the anti theft crap. so 100 dollars later the dealer called and said the reprogram was complete and the vehicle runs fine. after picking up the vehicle i drove for 10 minutes stopped at the store .and it will not start again .i did not have any power feeding the fuel pump again.no blinking security light or blown fuses. is there any hope or do i keep screaming at my truck ?


#2

Possible damaged BCM (where security program is stored) this is just a semi WAG.Can you talk to BCM with Tech2 scanner?

Typically the starter is disabled by Factory Theft (no crank) do you crank? how do you know no power at pump? 99 is early for pickups and Factory Anti Theft (they had the theft light but it did not do anything) something is not right.I am doing some homework now but will look further later.


#3

yes it does crank. when i turn ignition on i do not hear the pump come on. the light works. it was in an alarm state when i took it to dealer. thanks for any help on this.


#4

to anyone interested russels auto repair found the problem. there is a fuel pump relay located under the hood near the vcm . i was not geting a signal to this eaverytime. they removed the fuse box this was mounted in and found a “repair here button” there were chared wires under the fuel pump relay. after this was repaired my vehicle seems to be fine.


#5

Thanks for the update. The problem was most likely due to loose wire connections. This causes a resistance in the circuit connection and heat is produced when a high current runs through the bad connection.


#6

Can you see the “wild goose chase” that was started by the info "heard loud noise’ “replaced ignition components on the column” “I realized I had triggered the anti theft crap” Dealer said “reprogram was complete”. All this info was a total misdirection.

Did you go and ask for your $100.00 back?


#7

I DID NOT. FOR THE REASON THAT THEY DID THE JOB I ASKED THEM TO DO. WHICH WAS CLEAR THE ANTI THEFT THAT I MYSELF HAD TRIGGERED. I HAVE CHALKED THIS UP TO ONE VERY COSTLY FAULT ON MY PART FOR NOT CHECKING WHAT I KNEW WAS A FUEL ISSUE ,INSTEAD I TRIED TO AVOID DOING MY OWN RESEARCH,AND LOOKED FOR A QUICK FIX. I DO FEEL AS THOUGH I AM BETTER OFF NOW KNOWING THE FUEL PUMPS IN THIS VEHICLE HAVE A HISTORY OF PROBLEMS.AND I NOW HAVE A NEW ONE ON MY VEHICLE. I AM GLAD THAT THIS HAPPENED AT HOME AND NOT ON THE ROAD.I WOULD HATE TO THINK OF A TOW BILL FROM A VACATION ,WITH A CAMPER ATTACHED. AGAIN THANK YOU FOR ALL THE HELP.


#8

Thanks for coming back with the resolution. That’s the only way that the “we” out here in cyberspace learn what advice is wisdom, and which to set aside.
Did you know that in some societies that it’s considered very bad form to even have anger, and even much more inappropriate to have anger and to show anger?! Ain’t that cool?! Did you ever know of anger, and anger displays, to have constructive results?


#9

thanks for the words of wisdom. I have tried in many situations to not get angry , but to take some knowledge away from every situation.