No Dash Lights & No Start

chevrolet
s-10

#1

Cold start ok .Problem arrises after engine is at operating temp.After stopping for whatever and attemping to restart, dash no longer lights up with key in on position but starter cranks and engine won’t start. Leave key in on position for about a min.dash lights back up and engine starts.


#2

Oh good. Now the battery terminals will be cleaned. What happens after that is what really counts.


#3

It sounds like there is a bad connection to power between the ignition switch and the dash. Check the connectors running to the dash. Perhaps disconnecting and reconnecting them will solve the trouble.


#4

You may have a bad relay. The acc power relay may be getting hot and be out of spec on a hot restart. You could check your relay box some relays are identical. Swap a reletively useless one for the acc/ on power relay, like high/low beam, windshield washer… It has the advantage of being a pretty quick test, and cheap.


#5

If this truck has a junction terminal it may need to cleaned. This terminal is usually located near the battery positive terminal and should have a heavy wire lead to it.

If that is not the problem then a faulty ignition switch is possible.


#6

Thanks ,I always clean battery terminals before winter.


#7

( UPDATE ) Thanks TO EVERYONE WHO WROTE IN.OLD PROBLEM SOLVED ( BAD RELAY CONTACT IN STARTING CIRCUT )CHANGED OUT HARNESS.NEW PROBLEM CRUISE CONTROL , BLINKERS , AND KEY LOCK( ONCE KEY IN CYLINDER CAN NOT REMOVE WITHOUT MANUALLY DEACTIVATING )DO NOT WORK .4WAY FLASHERS ARE OK , BRAKE LIGHTS WORK ,BACKUP LIGHTS WORK ? THANKS AGAIN FOR ANY HELP.