Nissan Sentra Accelerator Issues

I have an 03 Nissan Sentra 1.8 with 200k miles. A year ago I started having an issue with the accelerator. When I drive the car the accelerator stops working. It idles perfectly, but when I step on the gas, I get almost no reaction. It does increase RPM about 200, but that is all. When I first start the car, the accelerator works for the first five to eight seconds, which leads me to think it is some kind of sensor. There is no check engine light.

I’ve tried replacing the throttle body (which includes the throttle position sensor), mass airflow sensor, and the fuel pump. I had it on to the dealership and they reprogrammed the computer, but the issue persists. Last bit of information I can think of is that the problem used to disappear when the car sat for a few days. So I had been driving it only once or twice a week. Unfortunately, the problem is now constant.

I’ve scoured the internet, but no answers. Many people talked about the throttle position sensor, which I replaced, but to no avail. Other users on this site have had the same issue, but none of the threads ended with an answer.
Your help is greatly appreciated.

A throttle position sensor is usually a potentiometer, with ground on one side, some positive voltage on the other and an in-between-ground-and-positive-voltage on the third pin. That variable voltage is in some proportion to how much your throttle plate is opened up. That level goes back to the computer that decides to adjust your fuel air mixture, among other things.
Using a multimeter, measure to make sure one side of that sensor is indeed attached ground, the other some fixed positive voltage* and that the third pin indeed varies when you open the throttle.

I’m not saying your TPS, the ECM or wiring to it is at fault but it is a place to start.

(*it could be anything, depending on your car. I’ve seen them to read 5V on Japanese cars. )

Not sure I have the skills for that, but I will certainly give it a shot, Thanks!

Perhaps ask your mechanic to check that for you. It seems like they are just throwing parts at it where it may have very well have been an intermittent connection to your Throttle Position Sensor. Now that they’ve replaced the throttle body, that intermittent connection may now be even worse. They’ve fooled around with the wiring, after all.

That’s the direction I’d start looking into first. It getting worse is a clue.

The only worry I have is that from what I’ve read, if you disconnect the TPS, then you have to get it reprogrammed. I may have to stick the probe into the wire sheath… does that sound right?

Oh, and I can’t blame a mechanic. I am the mechanic. Although the dealership should have been able to tell me more than they did. The most frustrating part is that while I have found plenty of people with this issue, no one has ever had an answer that actually worked.

Thanks for your help.

Reprogramming for a throttle position sensor? That just seems very unlikely, unless they have variability in their stocked parts and they make up for it by having it relearn each value. That would be totally hosed because it would imply that this part cannot be replaced by anyone other than a dealer. Also, how would it know that you unplugged it and it needs reprogramming?
Seems like bogus info but maybe someone here knows for sure.

How did you reprogram it when you replaced the throttle body, then?

I’d still check the wiring to it. It should have occurred to a half way decent mechanic worth some salt that perhaps the wiring is fouled up.

Edit: after googling that issue a bit, come to find out that the car does need to know about a new TPS. I guess the parts are variable enough that the car needs to get a reference. The good news is that this recalibration of the TPS, among other things, can be done by a user:

HAHAHA! You’ve found the same stuff I did. And in the same way.

BTW, the idle relearn procedure is so complicated that I could never pull it off even with a dang timer and the instructions right in front of me.

I plan to try the multimeter on the TPS tomorrow or Tuesday. Hopefully I can find something out.

From other things I’ve since read, not being calibrated the sensor causes it to limp, not going over a certain rpm.
Strange they have to do that, imo: There shouldn’t be any reason for it if that part of the design was tight. It isn’t like they are landing a person on the moon where you care about small fractions of errors in instrumentation. This is a half-an-axe-handle car, for crying out loud.

Anyway, reading some more on this procedure, not being calibrated does not seem to cause what you’re seeing. It seems to just go into limp mode.

Good luck with it. Report back on your findings. No doubt, between all the gear heads on this site, we’ll get it up and running again.


I won’t take the time to describe the HORROR SHOW I went through with the dealership, but they did find what seems to be the right solution! There were NO CODES and NO CEL for this problem, so they FINALLY hooked up a recording machine and checked out what was going on when the car acted up.

Drum roll please…

The alternator was OVERCHARGING when the gas pedal became unresponsive. Why? Who knows? But having changed the alternator, I’ve been driving for four days straight with no issues. So far, so good.

Good on you IKE! It is indeed possible for the alternator to put out too much voltage. All the snesors and such that control the engine depend on the voltage being withing certain limits, and if it goes outside those limits there no telling what the symptom will be.

Alternators work on the principle of magnetic induction, sort of an anology, if you put two tennis balls inside one of those tubes tennis balls are sold in. Hold it horizontally, shake it back and forth, and the balls go from one side to the other. The faster you shake the tube, the more force they hit the ends of the tube. The balls are sort of like electrons in the wires of the alternator and the force they hit the ends of the tube, the output voltage. So likewise, the voltage the alternator puts out depends on the engine rpm, the faster the rpm, the more the voltage.

So it’s not entirely surprising your problem occured when you stepped on the gas. There’s a circuit – part of the alternator output voltage regulation – that is supposed to check for overvoltage, and lower the magnetic field inside the alternator, so that the alternator output voltage stays within range (usually around 14.5 volts). I assume there was something wrong with that circuit in your car. I guess the shop you were using didn’t think it could be an over-voltage problem. An over-voltage problem could result in any number of symptoms, so that’s quite possible they didn’t consider it. It’s surprising the car’s diagnostic computer didn’t catch it though and turn on a CEL. Anyway, good on you to have this problem finally solved. And thanks for posting the final result, that info is helpful for others here to be aware of.