New radio now car won’t start

My car is a 2007 Mazda bt50 gen1 4x4 model.

I changed the radio in the car for a Bluetooth one and now my car won’t start.

-The radio and all other accessories work.

-I ran a small cable from the battery positive to the Solenoid on the starter and the starter would crank over but the car wouldn’t start (even with key turned in in position), which to me looks like the starter is fine.

-I’ve checked all the plugs and connection everywhere to make sure I haven’t knocked them lose and it all looks good

-the car had an old Nokia hands free phone system which I pulled out, it was spliced into the radio wires to get power so I don’t think by pulling it out I’ve created this problem, I dont think it had a car alarm in it cos I don’t have a remote for it.

-I’ve tried plugging in the old radio to see if it would start with that and no luck

-the ignition cable that runs to the starter is black with a yellow stripe which I’ve found at the ignition, when I turn the ignition on the cable gets 12volts to it, but when I meter at the starter motor the same black and yellow cable doesn’t have 12volts at it, so somewhere the connection is broken. I’m thinking it runs through the ecu and I’ve somehow disabled something.

Any help would be useful as I’m now stuck in what to do,


You removed old radio. And unplugged 1 connector from rear of HU? You used an aftermarket adapter to connect harness? No wires were cut?

Correct, but I also pulled out the old Nokia hands free device while I was in there which was spliced into the radio harness to pickup 12volts and ignition.
So I’m currently stuck, I have 12 volts at the ignition cable that runs to starter at the cars ignition, but not 12 volts at the starter. On the same cable.
So it’s an open circuit somewhere but no idea where.

Some anti theft systems depend on the radio unit. Maybe your Mazda is one of them. I can’t find information on line, so maybe there isn’t one. What does the owner’s manual say about it?


If you have 12 volts at one end of a cable, but not at the other end of the very same cable, it sounds to me like a defective cable. Are you sure you are talking about one single cable?

I’m pretty sure, it’s the same black with yellow stripe but it runs into the main loom which I can no longer trace it. And that look runs past the ecu so I’m not sure if it run through the ecu. There are cables everywhere and looms going everywhere with the black tape or flexible conduit around it and also it’s under the drivers side dash so it’s in an awkward spot.

It sounds like a circuit diagram is needed.

So I’ve narrowed down the problem further. The engine is immobilised. I check the manual which is should have done in the first place and the light on the dash flashes which indicates the engine is immobilised. Now I need to call Mazda or RACV to see how to fix this.
Unless anyone here knows how? The manual says take it in to Mazda.

I expect you’ll have to contact a Mazda dealership. The radio is part of the anti-theft system, and they’ll verify you are the actual owner, and only then will help you get it working again. There’s probably some sort of security code neeeded, and folks here almost certainly don’t know what it is.

This issue has been posted here before. You can use the forum search feature to see what others have done. Link, upper right this page.

… and an aftermarket radio might not be compatible with that system. It’s not clear to me whether the OP installed a genuine Mazda radio, or an aftermarket unit.

Yes, the dealership is probably his best bet, but if that radio and the car’s anti-theft system can’t “talk” to each other, the dealership may not be able to rectify the problem.

1 Like

In that situation the dealer may have to bring in someone to translate. Sorry I could not resist. :grin:

Yeah sorry it’s an aftermarket radio I’m installing. I pulled it from my old car which is the same generation bt50 (2009). My new car I’m putting it in is 2007. Different year but same generation. The difference is my new one is a 4x4 model. But same Facia kit and all.

You may have blown a fuse for the immobilizer system while removing the hands free system wiring. The fuse might be shared with other circuits and not labeled as “immobilizer” so check every fuse in each fuse box with a test light. Also try a different key.

1 Like

How much work would it be to reinstall old radio? To see what happens
Car is not running. I would prefer a running car

Yeah I’ve already tried that, it’s just the wiring loom needs to be plugged in.

So, it runs with old radio installled?

Nah engine is still immobilised. No luck. Mazda said they’d have a look at it but I’m worried it’ll cost a bit and it’s probably an easy fix, I just don’t know what. I’m gonna try swapping batteries tomorrow, I read that coil help.

have you tried disconnecting the battery and letting it sit for a while and then reconnecting it. maybe it needs a reset. if you have not its worth a shot.

For your sake I hope that it is, but if the new radio is an aftermarket unit, the “fix” might be to ditch that radio and buy a Mazda unit.

Yeah I’ve tried that as well. I also saw somewhere to short the leads while the battery is disconnected.