My car won't start after my husband changed out the radio pls help!

I have a 2007 Jeep Compass. My husband changed out the radio today and then the car wouldn’t start. It will turn over and over and over, but will not start. Any advice is appreciated!

Did he disconect the battery while switching radios?

One thing should not have anything to do with the other, but have you tried another key for the car??

Yoy might need a special adapter, here is one example.

hook up the oldradio, see if it runs, then look up your new radio @ and order correct adapter if needed.

If he did some rewiring he may have connected something to the CAN bus communication wires by mistake. This would prevent communication between the imobilizer module and the Powertrain control module.

Thank you for the tips. Yes he did disconnect the battery while he was working on it. I will try our spare key, but I don’t think that is the issue as the engine will turn over.

He did try reconnecting the old radio back up, and it still does the same thing. Also we ordered everything from Crutchfield, as per what they said we needed for this exact radio and my exact car.

I will tell him about the CAN bus communication wires though just to be sure. The only other thing is that my car has been having a bit of trouble over the last year or so with almost stalling out at lights and such now and then, and my husband is wondering if this is just a coincidence or perhaps disconnecting the wires was the straw that broke the camel’s back for this problem, whatever it is …

If he used a crutchfield cable, you usually don’t need to cut anything - just plug the thing into the car’s cable, plug the other end into the radio. If he needed to cut anything, something went wrong, I bet.

If the ECM is located near the radio, perhaps he jostled one of its connections loose while working on the car.

If your using adatper cables there is no cutting and splicing so disregard the Can bus statement. The problem may be with the electronic throttle control. After the battery cable is reconnected the throttle body goes through a brief calibration process the first time the ignition is turned on.

Try another battery disconnect then after reconnecting leave the ignition in the run position for ten seconds before cranking the engine.

Do you have a lightning bolt symble blinking in the instrument cluster? Does your keylees entry work?

The reason I said try another key is I wondered if somehow the car forgot about one if them. You car has an immobilizer that is triggered if a non programed key is used. This cuts fuel and or spark, but will allow the car to crank. If the second key starts the car you found your problem.

@gsragtop, can cars forget keys like that? I’m not saying it is impossible but one would imagine those sorts of parameters are flashed in the ECM.

Okay, to debunk a few things:

-The ECM is not located anywhere near the radio on this vehicle. (I think)

-If the car “forgot” the transponder keys somehow, it would still start, it would just shut off within a few seconds. That is the way this year of Chrysler vehicles behave when presented with a key that will turn the ignition, but that is ‘unknown’ to the system.

-If the electronic throttle control was out of calibration, the car would likely still start, but the throttle response would be weird and sluggish. Incidentally, the electronic throttle recalibrates itself every time you start the car I think.

-While it’s possible that something happened to the CAN bus wires, I think these are a twisted pair of wires, easily distinguishable from the rest of the wires. Plus, a CAN bus error would definitely store a trouble code in the computer.

What I would do: First, check all the fuses–there may be 3 fuse boxes on this car–one in the cabin, one under the hood, and one by the battery or elsewhere.

Read any stored trouble codes from the computer, either with a scan tool, or by the old trick of flipping the ignition on-off-on-off-on. The codes will blink out on the check engine light or possibly display on the odometer or “EVIC” display.

I would also try “rebooting” the car again, by disconnecting the battery for about a half hour, reconnecting it, then trying to restart the vehicle.

Okay, so neither of our keys will work to start the car. It still is turning over, but not starting. The key allows the keyless entry to work, also the radio, seatbelt warning sound, etc etc work.

The lightening bolt symbol is there, solid, not flashing. It only stays there for about 6-7 seconds then goes off, no matter if you try to turn the engine or not, until reinsertion of the key again.

My husband said that they only splicing he did was to splice the radio wire to the adapter wire. No splicing of any wires within the car itself. Plus, when he reinstalls the original factory radio (which he has now done twice) it still does not work.

Thank you all for the excellent suggestions, please keep them coming! We may yet fix this and not have to spend a fortune in towing & dealer fees! :frowning:

Is the battery fully charged? Maybe the connection from the battery to the starter or the one from the battery to the frame came loose? I’d start there.
Just plugging a replacement radio in shouldn’t do this. Clearly something got disconnected that shouldn’t have been.

It sounds like the radio is not the problem. I would imagine it would not crank if it were a security issue, so now time to figure out if is fuel or spark. Check the fuses, and fuel cutoff switch.

I agree - he probably loosened something. You can get a spark checker at harbor freight. It looks like a weird spark plug with a light in it that goes in series with any spark plug. If you crank it and don’t see the light flashing, you don’t have spark. If you do see it flashing, spray some starter fluid in where the air filter goes to see if it looks like it wants to start.

When your husband disconnected the battery, the Sentry Key Immobilizer System program was erased. This means the SKIS no longer recognizes the programmed keys. So each time you go to start the engine, SKIS thinks someone is trying to steal the vehicle and won’t allow the engine to start. Unfortunately, the only way to reprogram the SKIS is with a dealer scanner.

Here’s an article on what can happen when the battery is disconnected on a modern vehicle.


I wonder what it would do to new car sales if the salesman was required to tell potential customers about these “features” where you need to go to the dealer just to change the battery.

I really like that hypothesis except the engine will crank, but not start, Is engine cranks but does not start a possibility under the options you suggest mr tester?

I’m not doubting you, Tester, because you seem to know your stuff but to design a system that loses its marbles just because someone replaces a battery seems - sorry for the expression but I’m going to say it because there’s no other word for it - retarded or plain predatory.
In this day and age of cheap fast flash memory that is easily configured to be redundant there’s just no excuse for that.
If that’s the case, they did that deliberate to milk money out of unsuspecting owners. If so, that’s just unconscionable. There’s absolutely no technical reason for it. It means you have to get your battery replaced by the dealer. You left your dome light on and need a boost but it still doesn’t start? No worries - call the dealer and they’ll help you out.

The only reason why someone would design memory in like that is because they are morons or crooks.

No Keith. Like the article says, each manufacturer should have a warning on top of the battery and/or in the owners manual that states the concequences of disconnecting the battery or if the battery fails. Until that happens, we’re going to start hearing from more and more people having all kinds of problems with their vehicles after disconnecting the battery or when the battery fails.


Crazy stuff.
I miss the good ol’ days - like yesterday, when I still was under the impression you could remove a battery with impunity…
Anyone else?