Mercedes asr problem

mercedes-benz
e-class

#1

the asr system came on as soon as the outside temp reached +20 degree F. when the engine reaches normal operating temp the problem ends and does not return until the car(e320)cools over night. the trottle body assembly was replaced and that code ceased, but the problem remains.when the asr activates now, the engine increases to 1100-1500 rpm’s


#2

Stolen from

http://www.asashop.org/autoinc/july2005/techtips.htm

Mercedes-Benz was one of the first vehicle manufacturers to codevelop anti-lock brakes, with the Robert Bosch Corporation. It was also one of the first to equip its predominantly front-engine, rear-wheel-drive cars with traction control. Its acceleration slip regulation system (ASR) has progressed from ASR I, II, III and IV to the current system of electronic stability protection (ESP).

ASR I and II had no self-diagnostic capability. Since these cars are at an age where the systems are failing, they are being brought into independent shops for repair. The lack of self-diagnostics, plus the complexity of the ASR II system, can frustrate even the most experienced master tech.

Basically, ASR II combines the electronic and hydraulic components of the anti-lock brake system (ABS) with cruise control/idle speed control. To prevent wheel slip, ASR can apply the rear brakes individually to provide a differential lock effect and also control the throttle.

Let’s jump into the middle of a deep hole that a tech had dug with a 1992 500SL. This car was brought in with the complaint of “intermittent no power” and with the ASR malfunction indicator light (MIL) lit steadily. The throttle was in limp mode. In limp mode, the ASR system is disabled when the connection between the throttle plate and the accelerator is deactivated. The redundant mechanical linkage only provides about 30 percent throttle actuation. The driver feels a loss of power. A related complaint is, “It won’t accelerate.”

So logically, the tech started by troubleshooting the throttle control components of the ASR II system. These consist of a throttle potentiometer (R25) and a throttle drive motor (M16) that communicate with the electronic accelerator/cruise control/idle speed control (EA/CC/ISC) and the ABS/ASR control modules.

The technician had made sure the R25 was getting its proper 7.2v reference voltage. He verified low voltage drop on the ground circuit and a good voltage sweep on the sensor output. Specs: 0.59v at closed throttle to 6.5v at wide-open throttle. The safety switch in the pedal position sensor also seemed to be switching on at the correct control voltage, about 6.2v. The pedal position sensor was OK.

Next, he tested the actuator M16/1 that had 7.2v reference voltage, a good ground and a clean sweep on the potentiometer when operating the throttle linkage. Specs: 6.5v at closed throttle, decreasing to 0.70v when pushing the linkage all the way to the wide-open throttle position. The safety switch in the actuator changed at 5.9v. All good values.

So why would it go into limp mode if it is passing all the tests? The tech was ready to replace the EA/CC/ISC control module. I suggested he check the logic feedback of the control module by measuring the voltage on the actuator motor. When pushing on the linkage, the motor supply voltage to the actuator should reverse as a default to push the motor back to the closed throttle position when no input is received from the R25 potentiometer. It tested OK.

Something else was causing the car to go into limp mode intermittently. Diagnosis becomes difficult when more than one control module is involved in a system, or shares data with several others. Was it the EA/CC/ISC control module or the ABS/ASR?

The tech retested the inputs on the ABS/ASR control module. Starting with the powers and grounds at the control unit connector, he said all were OK. The tech went through the electrical test procedure he had on his shop information system. The resistances on the solenoid valves in the hydraulic unit and wheel speed sensors were OK, the wheel speed sensors all produced a good signal, and the voltage comparison from side to side on each axle was fine when rotating the wheels at a steady speed. The tech couldn’t find anything electrically wrong with the ABS/ASR system. At that time the MIL was off and the car was working normally, increasing his frustration factor.

When the system tests OK, functions OK and has no symptoms, it’s time to take a closer look - making sure everything actually measures up to the specs. I asked the tech to retest the power feed at the control module from the over-voltage protection relay (OVPR). I explained that we needed to see less than 0.3v drop from battery voltage on pin 1 of the ABS/ASR control module. The reading was 11.2v. Battery voltage at the fuse box was 12.2v … more than three times the allowable volt drop on the power feed circuit!

I suggested he drive the car until it went into limp mode, and then come back to the shop, switch off and recheck his key on, engine off volt drop. He found the voltage from the OVPR was dropping to 9.4v after the car had gone into limp mode. While the relay was not completely failing, high internal contact resistance in the relay was causing the control unit to quit working due to lack of voltage. The OVPR was replaced and the car had no further problems.

This illustrates the help that self-diagnostics can provide when testing complex interactive systems. If you choose to skip steps in the procedure, take short cuts or accept “close enough” readings on the specs, this can sidetrack your diagnosis and waste even more time. When performing test procedures by the book - go by the book. Don’t try to second-guess it.


#3

WOW! I will show a copy of this to my tech. This is my first time on car talk questions and I really appreciate the information, thanks…


#4

well I want to thank waterboy for his reply. After many hours of frustration, checking and re-checking, asking other expert tech’s, my guy discovered that the control linkage which had been checked numerous times and appeared to be working well, was failing to allow the throttle plate to close completely, and that sent a signal to the control unit which activated the asr. Lubrication of the linkage allowed the throttle plate to close completely. we could find no references on this situation in any of my manuals, or on any of the tech site’s that he normally uses. Thanks for the help. MM