Listening problems

All right, what gives? Why did those two morons–ahem, gentlemen–change the on-line audio delivery system? I cannot persuade Firefox (3.5.3) to accept the audio. The little red window comes up, says that it’s “Done”, and that’s all I get. Yes, I downloaded Adobe 10. Yes, I told Firefox to permit pop-ups &c. Nothin’.

Internet Explorer accepts it without a blink, but who wants to open I.E. when I already have twenty Firefox tabs open & a-runnin’?

Suggestions, anyone?

You could download and install iTunes for free at and download their podcasts. If you did that, you wouldn’t need to use your browser at all. Have you tried using another browser, like the browser that came with your operating system? If you have a PC it is Internet Explorer. If you have a Mac, it is Safari.

The OP does mention that IE works for them, they just don’t want to use it. I don’t blame them for this.

It still works for me with Firefox 3.5.3

Post me a link, My trial opens in windows media player, from firefox, anyone else?

Maybe the OP should re-install Firefox. I still think nothing beats the convenience of iTunes. You just subscribe to the Car Talk podcasts and it automatically downloads them as soon as they become available on Saturday. It really doesn’t get much easier than that.

Hi MJB1959,

This is from the Car Talk FAQ, at

Hope it’s helpful.


Doug Mayer
Senior Web Lackey
Car Talk

P.S. If the cookies fix doesn’t do the trick, email us directly via the Excess Bandwidth email on the site, and we’ll assign someone to try to help you.

Help! All I see is a red screen.

One of two things might be happening.

You may have a pop-up blocker on that does not allow the content to appear. Try pasting “” into the exceptions list in your pop-up blocker. In Firefox 3.x, if you don’t have the “Accept third-party cookies” option enabled, the player won’t work because the ads are blocked. Enabling this option in Preferences under the Privacy tab should make the player work.

Or, you may have the NPR ad server “firewalled.” You’ll need to change a setting in your computer’s operating system. Locate the firewall settings on your operating system and then unblock “” This should allow you to get beyond the initial underwriting credit, and hear the show.

Works fine with Firefox 3.5.4 and XP

Works fine with Firefox 3.0.14

Reboot the computer. Sometimes you have to do it when you reconfigure. It’s a computer thing.