Help with 2006 Toyota Solara Windshield Washer Pump

I have a 2006 Solara and overnight the windshield washer pump stopped working. I thought the problem was no washer fluid, filled it, and nothing. I checked the hose near the hood and nothing came out. The motor isn’t humming like it is trying to pump, so I checked the fuse (I think I checked the right one, not sure, it was a 15a) and it appeared to be good. I checked the wires going to the pump with a multimeter and didn’t get power, so is there any other “secret” fuse I am missing. I know on an older car I had, the fuses were sometimes mixed with other items and not labeled.

The washer fuse is 15a.

Have you tried checking the wiper switch?

There is a relay under the hood called the RAP relay that could be bad. You could swap it with a like relay to see if it fixes it. Fuse 8 could be bad.

I’d swap in a new fuse just in case. Check if you’re getting 12 v at the pump. If you are get a new pump. I’d use Rockauto if you can wait a few days.

I am not getting any voltage at the pump. I checked it with the voltage meter. I will try the fuse. Not sure where the relay is knfenimore, but I will look into that as well.


Are you checking for voltage while you are pushing the wash button?

Check across both wires leading to the pump with your voltmeter while pressing the button. Then check from each wire to ground. On an Oldsmobile I once owned, pressing the button completed the circuit to ground.

The circuit path looks like it goes like this:

+12 volts from the ignition (key in “on”) power source
fuse 15A
2c-pin 11
first washer motor terminal (pin 2) (L-W wire)
second washer motor terminal (pin 1) (P wire)
IG8-pin 9
pin 11 of the combo switch … pin 11 is connected to pin 2 by enabling the washer switch
pin 2 of the combo switch …
junction connector 4
chassis grounds II and IK

So the first check, there should be 12 volts (i.e. battery voltage) on pin 2 of the WW washer motor terminal whenever the key is in “on”.

Note: I think “15A” is the amp rating of the fuse, not the fuse number. Look in your owners manual for the fuse number. There are probably more than one 15 amp fuses.

You should have 2 wires going to the pump, the pink is the ground from the switch and the blue w/white trace is power from the 15A wash fuse. The 15A wash fuse is located in the fuse block on the drivers side of the dash. You should have a constant 12v when the key is on at the pump connector and continuity to ground when the washer is turned on.

The problem has fixed itself. After plugging it back in, apparently it mysteriously works now. Wife said she tried it this morning and it worked fine.

It’s amazing how often this same technique works for me. Seems things have the ability to fix themselves by magic sometimes. A while back I was having a problem with the carb’s accelerator pump on my truck. Like the Rolling Stones say, when I pushed on the gas pedal, I got no satisfaction. I consulted here, got some good advice, explanations of how it worked, so with this add’l info I popped the hood and looked at it, twisted a couple springs, pushed on a couple of gadgets, decided I didn’t have time to figure it out and complete the job and closed the hood. Next time I used the truck the problem with the accelerator pump was fixed … lol … and its been working fine since …