Comfort Control Module Blues?

I think I may have CCM problem but not sure, have tried to diagnose/fix but now I’m stuck: 2000 VW Passat sedan, 71K, automatic trasmission.

History: Big rain storms 1 week ago. Found 1/4 inch standing water drivers side (you see where this is going). Wet corner near drivers side of sunroof, and flooded sun roof gutters, suggested that water leaked in through sunroof and came down column near rear view mirror and onto floor. Car seemed otherwise fine. Has worked fine for a week, including being driven long and short distances, and multiple errands (on/off/on/off with electrical, engine, etc).

Symptoms: Last night left work, remote key did not work to open car. Opened with key manually. Found that the following did not work: dome lights, trunk release, sun roof, windows, unless they were lowered/raised by using the key in the door, and car would not turn on. The headlights and radio did work. Needless to say jump start did not work. Had car towed home, as was 9pm and did not have mechanic to drop it off at (long story). Found that key batteries dead too (tested w/ volt meter); replaced batteries in case alarm was preventing car from working, didn’t help, but needed to be done anyway.

Plan: Mechanic friend came last night and tested battery and all fuses, all checked out normal. Not much else he could do at midnight and not in his shop. Today, after talking to 3 mechanics, determined that CCM most likely problem. Pulled up carpet, located CCM, removed. Condensation found around cable bundles/under carpet and insulation, which are still very damp. No condensation inside box, opened CCM, no evidence of moisture in there. Put heater in car to dry, left CCM open (but covered to avoid dust collection) for several hours. Carpet dry on top, still damp underneath of course. Plugged CCM back in, checked all plugs near where those cable bundles go into car on left, below fuses, to make sure dry and not loose.

Status: ARRGGH! Still won’t work! My CCM did not seem wet. Is it possible it’s done for anyway? Or is the problem most likely elsewhere? Any ideas for my next steps?