CarTalk.com Best of Deals Car Reviews Repair Shops Cars A-Z Radio Show

Chevy pickup truck problem

My husband is having problems with his 1995 K1500 5.7 L Chevy pickup truck. It has 200k miles on it.



When we were out on Saturday, we tried to start the truck, and nothing would happen when we turned the key. We could get headlights and clock to come on, but no power at all besides that. So we tried to jumpstart it, but the battery was still reading low. We took the battery to Auto Zone and tested it; and the battery is good. They recommended the starter. So we replaced the starter. As we were hooking back up the battery after installing the starter, the engine started trying to turn over while no key is in the ignition (and the ignition turned to off). So we thought maybe it was a bad ignition switch, but after changing it out, the problem still occurred.



We do just about all our own car fixin’, and this has us stumped. Hubby’s best guess is a short somewhere in the electrical system. Me on the other hand think it’s possessed and needs a priest.



Anyone have any good ideas for things to try? Or if it is a short, an easy way to find it?



Thanks!

When you changed the ignition switch, did you change the actual electric switch, or just the lock tumbler?

Also, are you sure that he connected the starter correctly?

Yes he connected the starter correctly. I think the old one was bad as with the old one it wouldn’t try to turn over. Now it tries to turn over when we don’t want it too!
Ignition switch I do believe… lots of long wires under the dash.
He did something where he put a multimeter between the battery (I think it was the negative terminal, but don’t quote me on that) and the engine block and read a voltage. If you do the same thing with my properly functioning Honda Accord, it reads no voltage. That’s why he thinks it’s a short.

I don’t think you have a short problem but there does appear to be a bad connection in the power buss somewhere. From your description of things it sounds like the new starter motor has a problem. Try disconnecting the small ignition wire going to the starter solenoid and see if the problem still occurs. If so, the starter is bad.

I kind of think you may have jumped the gun by replacing the starter motor but if it is the original one you were most likely due for one soon anyways. The problem you are having may be in the main power buss area, a faulty relay, or the safety switch may be bad. You should get the warning lights to come on when you turn the key from OFF to RUN. If that isn’t happening you then need to see why power isn’t getting through the ignition switch. This again points to a problem in the main power buss under the hood. There may also be a bad fusible link causing this trouble.

EDIT: Verify that fuses 5 and 6 in the panel under the hood are good and have voltage on them at the small slits on top of them.

Take the starter back out. Get a pair of jumper cables. Attach the positive cable to the positive battery terminal and the other side to the battery connection on the starter (the large copper post). Do NOT let the cable touch anywhere else on the starter. Attach the negative cable to the body of the starter. With the starter on the ground, put your foot on it to keep it from moving and touch the other end of the cable to the negative battery terminal.

If the starter turns the starter’s solenoid is stuck and bad. If the starter doesn’t turn you’ve got a shorted ignition switch.

Sounds like after you hooked the wires up to the new starter they have become miss-positioned (the big cable is touching the solenoid wire) causing unintened starter activation.

Take a second look at the wire position, GM pick-ups always were a little hard to install and keep the wires lined up right.

The switch solenoid may be frozen (welded internally) Take it off the starter and get it apart or test it as suggested and when it fails, return it for a good one. It should be the starter solenoid assembly that is causing the problem. If the wires on the solenoid (if there are two small ones) are touching, it could cause the problem. Careless installation will do it.

The starter was replaced by my husband five years ago. It was an Auto Zone one with lifetime warranty. All we have to do is take the old starter back and we will get our money back in full.
He’s checked the fuses, but the relay and safety switch were two thoughts that he was having too.

I’ll tell him to try that. However, Auto Zone tested it twice for us and everything was working fine. I’m guessing that when they tested the starter they tested the solenoid too?

I’ll tell him to check it again. We’re having it towed back home so we can work on it easier.

I had a problem like this on a Dodge van once. In that case it was a wire from the ignition switch to the starter was grounding out. The insulation had worn away and it was touching the engine block. In you case I would suspect either a bad solenoid, as others have suggested, or possibly a bad starter relay (if it has one). It’s also possible some wire is shorted out as I had. I think I’d first just disconnect the small wire on the starter. If it keeps turning, then it is surely the solenoid, if not then follow that wire . . .