Airconditioning off and on in 2001 Nissan Altima

#1

My airconditioning in my 2001 Nissan Altima works off and on, sometimes it blows nice and cold and sometimes it is not cold at all. I took it to my mechanic a few weeks ago and he put some freon in it but it really isn’t better.

If anyone has any ideas what might be wrong and what needs to be fixed, I’d like to hear it. Thanks

#2

Is there any correlation with vehicle or engine speed?

#3

Does it give hot air when you are accelerating hard, but returns to normal when slowing down?

#4

If the refrigerant was low there is a leak. If the leak has not been repaired the refrigerant will leak out and the AC will not work.

There are several possible causes for this problem. Low refrigerant level is one. Take the car to a shop that specializes in automotive AC systems. They will do a correct diagnosis and repair whatever needs to be fixed.

Just adding refrigerant is a band aid.

#5

Thanks, that’s what I’ll have to do. It’s just strange that sometimes it’s cold and sometimes it’s not. There doesn’t seem to be a relation to engine speed nor does it give hot air when accelerating hard as described above. I would think that if it were a leak, it would gradually get worse and worse, not sometimes great and sometimes warm. I just wanted to go into the airconditioning place with a little more knowledge than I have right now. Thanks for your comments.

#6

Could be a sticking mixer flap or flakey flap motor. This is the flap that mixes clod AC air with warm heater air depending on where you have the temperature selector dial set.