99’ Jeep Wrangler Problems Please Help

To quickly outline the issue, let me explain how it started. I have a need for a kill switch in my 99 tj due to some mischievous friends. One of my switches interrupts the pcm circuit of the ASD relay. (blue and yellow wire) I did a poor job wiring and one of my soldered connections left me stranded. I was unaware that was the issue so I put a jumper in place of the relay because I figured it had gone bad. Eventually I got the chance to clean up my connection from before and resolder the wires.

Now the issue I’m experiencing is an absolute mystery to me. I think as a result of my jumper, the battery died. That was no problem, and I recharged it and put it back in the jeep. With all connections restored, I tried to start it and it has the same issue as before. Crank but no start. After lots of testing, I eliminated the switch and wired the relay up exactly how it was to begin with, but still no start. Here is a list of everything odd it has done over the period of my testing:

-relay chatter from only asd relay

-mystery continuous beeping with no key and ignition off

-strange battery drainage all the time

-threw the asd circuit code(has since gone away)

-threw p1492 (battery temp code)

Things I have tested:

-the relay works well

  • the constant 12v has constant 12v

-the constant ground has ground

-the ignition 12v has 12v when ignition is switched

-the pcm ground has continuity with pin 3 of the pcm

-all fuses are in tact

This lead me to believe it is either the pcm, the data the pcm is receiving, or the ignition. The pcm performed fine until I parked it to repair the connection. The same is true for the distributer pickup(cam position sensor) and the crank position sensor. Regardless, I tried and ultimately failed at receiving conclusive results from testing both these sensors. My doubts are high as to both of them going bad so I chose to call that my own error. That leaves in my mind one final problem. The ignition switch. It has always been a little touch and go but nothing a little key jiggling couldn’t fix. I find it hard to believe that this could be the issue either as it had worked for so long. I am lost.

I’ve been at it for a couple afternoons now and may have missed some part of the story which hopefully isn’t crucial but everything listed should be correct. Sorry for the whole book of info, but I am beyond lost.

I think you should just tow it to a shop. Let someone fresh have a look. But the basics are check for spark and fuel pressure to see what is missing.

Been there a couple times. I thought I had a wiring problem and replaced a wire. According to the factory manual it was the black wire in the harness. Guess what? Three black wires. Picked the wrong one. Ran terrible. Shop found a dead short to one injector. I think it only cost $100. Another time I took my seats out to clean the carpet. Wouldn’t start afterward. Spent a day looking for the problem. Shop found a missing fuse. Another $100. Tow it. Fresh eyes.