91 Nissan pick up starting issue

nissan

#1

I have a 91 Nissan pick up that is just making a clicking noise upon trying to start it. I replaced the battery. The inside light works, radio works, dash clock works, but still just clicking upon trying to start. Is there a clutch safety switch that could cause this, or starter, or ??? I’m open to suggestions.


#2

There is a clutch inter-lock switch that prevents the starter from operating unless the clutch pedal is depressed. But if you hear a click when turning the key to start it’s not the inter-lock switch. Check the starter relay.

Tester


#3

@AKGrandma

That click could be the starter solenoid

Do you have a multimeter?

Make sure the starter gets a voltage signal when you try to start it

If it is, the starter has failed


#4

There is a safety switch used in the starting circuit but if you are hearing multiple clicks while in the START mode then there may be a power connection problem in the wiring for the ignition switch. If you are just hearing a single fairly load click then that would point to the starter solenoid contacts being bad or the main battery cable going to the solenoid has a problem.


#5

have bypassed the clutch safety switch, bench tested the starter, got a tester for the ignition switch, tried push starting, still just minor clicks


#6

You need to check to see if 12 volts is getting to the safety switch when you go to the START mode. If that is good then you need to see if 12 volts is getting to the small wire of the starter solenoid. Applying 12 volts directly to the solenoid connection should activate the starter. Make sure the transmission is not in gear if you bypass things.


#7

I don’t have a tester for 12 v to anywhere. i did replace the starter assembly. it has started snowing, so might just push it into the grass and leave it for next year. I did ask on craigslist for someone with a tester.


#8

You can purchase a test light probe at any auto parts store for around 10 dollars.


#9

broken piece in the rotor cap, so replaced that, then went ahead and replaced starter. so, with a new battery, starter, rotor cap, still not starting. had a friend come over with a tester, and guess what, it was the starter relay! Thanks Tester! it’s now running!