5.7L TBI Hard Hot Start

start
gmc
2500

#1

My 1995 GMC PU has a 5.7L TBI that has an odd problem. It will start cold fine. If you drive and stop, and let it sit for say 20 to 30 minutes, it is hard to start. After much cranking, it will start, chug a bit, rev up, and then settle back down and be fine. If you stop it hot, and re-start within say less than the 20 minute, it starts fine. If you wait longer than the 30 minutes, it starts fine. It’s only hard to start hot when it “heat soaks” for a while


#2

Try checking your ignition module. My Silverado had a similar problem and that fixed it. Take it to your local parts store chain and they can test it. Advance Auto Parts did mine and sold me a new one for forty or fifty bucks. Good luck. T


#3

I replaced the ignition module in '07 in an attempt to fix the problem. It didn’t. Someone mentioned the pick-up coil could be the problem. I did not replace that as I could not get the distributor bolts out. I was afraid they’d break off.


#4

Remove the air cleaner and look down the throats of the throttle body with a flashlight. See the two injectors? Watch and see if they drip after a hot shut-down…If they leak, they will flood the engine, producing a hard start…


#5

I replaced the injectors some time back, as I thought what you mentioned may have been the problem. It was not. Still did it after new injectors.


#6

Have you looked at what the injectors are doing when it won’t start? Have you tried turning it over with the pedal to the floor (which should put it in clear flood mode and cut off the injectors) to see if that expedites starting any?

I would add the coolant temp sensor to the “worth a try” category since it’s a $10 part on this truck and could possibly cause this.


#7

I am 99% sure that I have replaced the coolant temp. switch. Can’t find the receipt, but I think I have replaced it. I’ll get another and put it in.

I have tried to start it with the pedal to the floor and that doesn’t make a difference.


#8

I replaced the CTS and still have the problem :frowning: