CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

2005 Ford Expedition - A long list of CEL codes

P0012
P0174
P0300 2x
P0345 2x
P0012
P0138
P0174
P0302
P0303
P0304
P0340
P2196

Getting these codes on a flashing CEL. Misfiring bad running very rough at idle no power hit the gas in drive and no power at all just bogs down. Recently had major battery problems and had to jump it quite a bit couldn’t find the drain wife hooked up battery wrong she said their was a flame in the ground side so this tells me it was hooked up in reverse polarity I dont know if it’s Cam phasers or PCM or what but I’ve changed both Cam sensors and cleaned the MAF sensor please help

Don’t know yet how much damage reversing cables did. But the first thing to do before you can go any further is to have a healthy battery working in this vehicle. Many of the codes may be as a result of battery incident and may go away. When you have a good battery record codes then clear them. Restart vehicle, but don’t let it run long when CEL is flashing. Then repost new codes here.

3 Likes

If she saw a flame, look for the burnt wire, check the ground for resistance, check the battery for voltage. Assume you might have fried the ECU.

3 Likes

Actually I forgot to mention that I did replace the battery after that with a new battery brand new

Can you read codes?

1 Like

Yes. It’s still kicking codes out all 14

It is now becoming more difficult for me without having hands on. I don’t know how many of these codes could have been generated by a fried PCM. Did you try to clear codes yet after battery incident? If we could trust the codes, I’d go after the variable timing issue. Maybe someone with more experience can jump in. If you cleared codes and these returned. Then we might start chasing them.

1 Like

After the new battery install is when it happened and all the codes started kicking out and yes I’ve cleared all codes and they come right back thank you everyone for all your help

Variable camshaft timing could cause many of your symptoms. Theres a VCT oil valve that could be not working, oil pressure to the VCT could be off, the camshaft phaser could be sticking.

1 Like