1996 isuzu rodeo problem

So I purchased my first car, a 1996 isuzu rodeo, about a month and a half ago, and it was running fine until when I was driving the pedal stuck to the floor and didnt come back. After I had pulled over I used my hand and lifted it back up but when I tried to push the pedal back down it made a grinding sound. I ended up turning off the car and now it wont start and I’m able to go in and out if gears without the pedal. I’m going to replace the slave cylinder and I’m hoping that fixes my problem. Any other suggestions?

If you put the transmission in neutral, and step on the clutch, the engine should start without the vehicle moving.

If it doesn’t, you’ve got bigger problems.


Yea that’s how one starts a manual, but it wont start that way. I got it to start somehow earlier, but it only did it once and still made that grinding noise.

Which of 4 pedals are you tslking about? Tester assumed clutch. So which is it? Gas, brake, clutch or parking brake?

Clutch, should have been specific my bad.

When the engine is off it’s normally possible to change between gears without depressing the clutch pedal.

Usually the clutch pedal has a hefty return-spring attached to it. Easily visible near the clutch pedal. Is the spring missing, or has one end fallen off?

Do you mean it won’t crank? You don’t hear that rr rr rrr sound with the key in “start”? If so that could be the clutch safety switch is somehow being affected by all this. That switch gets depressed by a tab on the clutch pedal ass’y when you press on the clutch pedal. It is also easy to see, although not as easy as the spring. It’s purpose is to prevent accidental starting.

If the grinding sound is from the clutch pedal assembly (inside the passenger compartment), that might be a minor problem, something came loose near the clutch pedal. If it is coming from the engine compartment you likely have problem that will require the clutch workings be exposed, which means the transmission will have to be removed.

Generally a failing clutch master cylinder shows up as you press on the clutch pedal, but it is more difficult to change between gears than usual. And if you press on the clutch pedal a couple of time quickly in a row, that helps. If the clutch MC ran out of clutch fluid this could happen though.

So after I posted this I went to my moms camero and messed around with the gears on that, and i found out as you said that it’s common for gear change during no power. By not turning on I mean not cranking, the dashboard lights up, but the car doesnt do anything. The reverse lights also come on when I put the stick into reverse. This model does not come with a neutral safety switch as far as the Haynes manual says.

The neutral safety switch is only used w/an automatic transmission. But there should be some sort of clutch safety switch on your manual transmission clutch pedal. I’m seeing reference to both a “clutch switch” and a “clutch interlock switch” on the 96 rodeo 2.6L. I’m guessing the “clutch switch” is the safety switch mentioned above, and the interlock switch has to do w/the cruise control function. The clutch switch is oem part number 8943330871.

I’ll look into it, I’ve got the 3.2L v6 4x4.

The 3.2 uses a clutch switch too, but different part number: 8943683430

So I looked at the part and I remember seeing this and it presses like a button with a spring behind it.

Yeah, that sound like the clutch switch. If it isn’t in the “on” state (which it should be when the pedal is pressed), then when you turn the key to “start” the solenoid terminal of the starter motor won’t get energized. So you get a no crank. You won’t hear anything, not even a click when you turn the key to “start”. It may be that the clutch switch is actually working, but you aren’t pressing on the clutch pedal when you turn the key to “start” (b/c of the other problem).

Yea that’s exactly what’s happening, I’ll give it further inspection when I get the chance and make sure a wire didnt come loose or anything.

Sounds like you are on top of the problem. Good for you.

Reminds me of a story. I had owned my Corolla for 9 months or so, started every time, when one day it wouldn’t crank. I couldn’t figure out what the problem was. Turns out I was testing something and had to have one foot outside the car, so wasn’t pressing on the clutch pedal … lol … I never knew until then you had to press on the clutch pedal to crank the engine, just did it automatically.

1 Like

I appreciate the help

Unfortunately I’ve tried not pressing the clutch, pressing it, pumling and trying to start it, none of them work.

So I looked at the switch and i didnt see anything abnormal, I’m really confused as to why it’s not making any noise

With the key in “start” both terminals on the starter motor should measure at least 10.5 volts, probing between the terminal and the starter motor case. If you tell us what voltages you are measuring folks here might be able to suggest what to do next.