CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

1994 Toyota Pickup - Help with MAF issue

Truck stopped running aprox 1 year ago. No real reason. Model is Deluxe, V6, 60k miles, always well maintained, excellent condition,.
Replaced fuel filter, fuel pump, distributer, Zilch. Three months ago I replaced the MAF and plugs. It finally started. Drove around and all OK. Two weeks ago and it wont start again. Same as before, turns over wants to start but wont. Spray throttle cleaner into engine and will run only few seconds.
Help.

Could have clogged the injectors running it on that stale fuel.

1 Like

There is ALWAYS a reason, otherwise it would still be running. So is the check engine light on? You need to find a scan tool that can read the stored codes.

You just changed a bunch of parts and managed to get it started. But now it stopped. What did you do to determine that it needed a fuel pump? Distributor? MAF? What tests did you run to determine these were bad?

That tells me there’s a fuel problem.

Check if the 15 amp EFI fuse has blown.

Tester

5/25/20

Thanx for your reply. The fuel is fresh. Also, the tank was
cleaned and has fresh fuel. The fuel fuse is also ok.

Later,

5/25/20

I have been trying to send you more info about this issue from my other pc/mail.
Using T-Bird Moz://a and am unable to send any email to anyone.
I will still try and get that info to you soon as possible. I may have
to recreate all the info for you on this pc. The only issue is I am not sure if you
can read what I send.

Later,

There is ALWAYS a reason, otherwise it would still be running. So is the
check engine light on? You need to find a scan tool that can read the stored
codes.

You just changed a bunch of parts and managed to get it started. But now it
stopped. What did you do to determine that it needed a fuel pump? Distributor?
MAF? What tests did you run to determine these were bad?


[Visit Topic](https://community.cartalk.com/t/1994-toyota-pickup-help-with-maf-
issue/164645/3) or reply to this email to respond.

To unsubscribe from these emails, [click
here]
(https://community.cartalk.com/email/unsubscribe/afb02a1337283ffc23a4d6c4c664add9c9d
36dd3841adda07531f0f39ed67c4c).

Quit trying to reply through email, if you’re on a pc, just go to the website here.


and use the reply button.

1 Like

Mustangman

Thanx for your quick reply.

 *The check eng lite did come on before changes were made.

 * Only have an OBD2 Scanner, the truck is n/a to OBD2's.

  * Parts were changed on the advice of several "so-called" mechanics with many years knowledge.

  * The MAF and plugs I did on my own.  This did work but only the one time.

  * The fuel was dumped and is fresh.

          Later,

So is it still on?

Then you need a OBD1 scan tool to read the codes.

Since it runs on throttle cleaner, agree with @Tester… is the 15A Fuse blown?
The fuel pump needs power and a good clean ground to run. Check that with a volt-ohm meter at the pump. Make sure there is voltage at the 15A fuse. If that is good, make sure the injectors are firing. Use a noid light or a volt-ohm meter with a PWM function while you are spraying cleaner into it.

If you don’t know what the stuff is I posted in the previous paragraph, you need to take it to a mechanic who has these tools so they can diagnose the problem. Otherwise you can only continue to blindly change parts. And we know that hasn’t worked so far.

I am really having a hard time trying to figure out how “Car Talk”, how to properly
reply to all of you, etc.,. Car Talk vs emails,. confusing to me.
I really appreciate all the help, assistance and time you have given to me.
You have all been very helpful. I am trying to get an OBD1 scanner and will continue
to struggle through this the best I can. I will try and keep you posted.
Thanx again for all of your help…….

Ricco

I am really having a hard time trying to figure out how “Car Talk”, how to properly
reply to all of you, etc.,. Car Talk vs emails,. confusing to me.
I really appreciate all the help, assistance and time you have given to me.
You have all been very helpful. I am trying to get an OBD1 scanner and will continue
to struggle through this the best I can. I will try and keep you posted.
Thanx again for all of your help…….

Ricco

Simple thing is to logon to the Cartalk Community . As for email your replies are seen by everyone so need to post just to one person. Sometimes an email response makes those annoying texts that makes people scroll .