1996 Nissan Pickup - MAF sensor

nissan

#1

MAF sensor recently failed which was replaced and now the truck rough idles or dies when coming to a stop. while driving truck runs fine.


#2

Where did the replacement MAF sensor come from and how long has it been in the vehicle? If it is from a salvage yard, it may never work right. New MAF oem sensors are no longer available but non-oem replacements are available on amazon and ebay. They are a crap-shoot as about half of them don’t seem to work according to the reviews.

I got one off amazon and it worked. I think the main issue is that the installer did not disconnect the battery for at least 10 minutes after installing the MAF. That is needed to erase all the “learned” programming. If your was recently installed and the battery wasn’t disconnected for 10 minutes, the PCM will learn the MAF sensor eventually and the truck should run OK, but its quicker to disconnect the battery first.


#3

Thanks for the info Kieth. I’m going to try this trick out tonight, i will let you know what the outcome is. BTW the sensor was order by a local shop but after i had problems i purchased another one from amazon and it did the exact same thing. So hoping this works and i dont have to buy another one…
Stuart


#4

What was the code that made you think it was the MAF sensor?

On a 22 year old car, I would be checking the air tube between the MAF sensor and the throttle body for cracks or being loose at one of the air tube connections.


#5

The MAF sensor on this engine is located in the throttle body itself.

http://repair.alldata.com/alldata/imagesWLinks?file=/imagebfl300b/14/91/51_ns97truck_smec-093a.png&width=400&height=279&displayType=print&imgRotation=0

Tester


#6

MAF went out about a year ago and the truck was acting the same way it did then. The mechanic checked it out and seen that the sensor had cracked on the replacement. why or how it would crack makes no sense. Im not sure what the code was to be honest and Im surprised that with the current problem i haven’t seen a code yet.


#7

Idles badly but drives ok can be a too-lean condition at low rpms, often caused by vacuum leaks. So check the obvious culprits for that. It may be the shop that fixed the MAF forgot to hook up one of the vacuum lines, or hooked it up incorrectly . There’s usually a vacuum line diagram on the underside of the hood, near the emissions & tune-up info, so check what you have compared to that diagram. Beyond that …

The 2.4 L 4-banger engine seems to use a computer-controlled idle air control device as well as an idle adjusting screw. As long as the idle adjusting screw wasn’t changed, give it some time as it may figure out how to get the correct idle rpm itself. If the idle adjusting screw has been changed, or the computer can’t ever figure it out, there’s 6 pages of instructions in the repair manual on how to deal with incorrect idle rpm using the Nissan scan tool. Before starting down that list, make sure all these are working correctly: battery, ignition system, oil and coolant levels, fuses, vacuum system (including make sure there are no air leaks in the pcv system, at the oil filler cap, etc), fuel pressure, egr, throttle valve, and evap purge valve.

One other idea, problematic throttle position sensor. There’s a revised adjustment procedure available if you think it might be out of adjustment.


#8

Great info i will be busy with this. Here’s all the info i can give you. when i first got the truck back i had the bad idle and stalling condition by the time I made it home. i haven’t taken it back to the shop because they did leave off a vacuum line, vent tube and there is a cage like thing within the air filter housing that was also left out and found down on the side of the motor. So not going back.
Since getting the truck back i have replaced plugs, wires, cap and rotor. This helped a bit but did nothing for the problem im having. i found one video online of a guy having somewhat of the same rough idle situation. It showed him disconnecting the coolant temp sensor and the truck would smooth out and idle good. i tried this and had the same effect where my truck would start idling better with the coolant sensor un hooked. i left it off and did a little test drive and truck still would die when i stopped so i plugged it back in and did not replace it. Figured either sensor is bad and i need to replace it or it really isnt the problem. thats all Ive done so far.


#9

check for any vacuum leaks, as it was suggested up in this thread, it is very likely root cause of the issue. I would consider using “smoke machine” to detect any leaks not visible to the naked eye. YouTube is your friend, and you can make your own one for $10 or so if you have a few things like an old paint can, resistance wire, wick and an air compressor available

consider cleaning the throttle plate and idle control valve if your car has one

as for “mating MAF to the car”, the usual Nissan procedure to that (at least in newer OBDII vehicles) is:

  • have OBD code reader/cleaner ready ($10 bluetooth adapter and a smartphone will do)
  • warm the car up to normal temperature
  • disconnect the MAF
  • start the car for 5 seconds or so, until “check engine” lights up
  • shut down, reconnect the sensor
  • turn on ignition, do not start engine
  • use code reader to find P0120 or such error code, CLEAN it
  • make sure to have AC or other power draws off
  • start your car, let it idle 10+ minutes

at that point, ECM “learns” your new MAF and you are good to go

if your idle is very unstable after that, likely you have otehr reasons, ilke a vacuum lear, which is the first one I would address if I was you

good luck


#10

FYI, this throttle body as a two part throttle position sensor (TPS). Actually it is a TPS combined with an Idle Position Sensor (IPS). There are six pins on the connector to it, three for the TPS and three for the IPS. The IPS is two switches one that makes on when your foot is off the throttle and the other when you have the throttle floored (wide open throttle or WOT). The other three pins go to a rheostat which is a wire wound resistor with a wiper arm.

It has been a while since I worked on my 97 (same as 96) and the FSM is a little confusing because it shows the component differently than the two plugs that go to the connector. I had to use an ohmmeter to figure out exactly which was right.

The IPS is pretty reliable, the only issue with it usually is when someone “adjusts the idle screw”. What looks like an idle adjustment screw is really a throttle stop to prevent damage to the throttle body when the butterfly closes. It can be screwed in to the point that it partly opens the throttle, but when that happens, the closed position switch on the IPS will no linger make as it appears that your foot is on the gas. When it doesn’t make, the PCM (computer) also thinks your foot is on the gas and no longer sends control signals to the IAC (idle air control).

The wire wound resistor and wiper of the TPS is open to air and stuff can get in there. When your foot is off the gas, the voltage on the wiper is minimum, but there is some voltage by design for the PCM to use. The wiper usually gets dirty on the idle end first for some reason and when contact is broken between the resistor and the wiper, the voltage goes to zero and the PCM gets confused, even though it may still see the IPS signal. You generally get a P0120 when that happens.

You can clean the TPS by removing it and soaking it in some alcohol or spraying it with MAF cleaner.

BTW, I lost my truck to a distracted driver but I still have the factory service manual if your interested. PM me, I’ll send it to you for just postage. The 97 was not changed from the 96 as they were working on the Frontier which came out mid 97.


#11

I will gladly take the service manual off your hands. let me know the easiest way to get you some cash. I’m new to this site so Im not sure if this a PM.
So i disconnected the battery for a good 15 20 minutes. drove about 50 miles today and truck runs no better than before. Maybe this thing is a slow learner! i also did the quick and easy check for vacuum leaks using brake cleaner to spray around the vac hoses. im pretty sure its not a vac leak. truck acts like the idle is to low and its trying to compensate for it but stalls out. still no check engine light.


#12

Click on the avatar or if you prefer to call it the round circle beside the name of the person you want to private message . You will see a box that says ’ message ’ click on that and post away.


#13

Coolant temp sensors aren’t a common failure item as reported here. Suggest to defer on that idea until the more likely candidates are explored. CTS’s are easily tested, as most of them are just temperature-variable resistors, and can be quickly checked just by unplugging and measuring their resistance, then comparing to the spec chart of ohms vs temperature.

If there’s anything at all non-standard in the way the air path is configured from the air intake to the throttle body, that’s a very common cause of this sort of problem. Like a tear in the rubber air intake boot. Such a thing disturbs the air flow pattern and makes the MAF wildly inaccurate. There’s often things that look like giant bananas, appendages to the rubber air boot, and those have to all be in place. Those provide a source of already cleaned air, available to deliver to the engine without delay, for when you step on the gas. As I recall somebody here said those banana things are called “resonators”, something like that.


#14

this is completely off topic but i followed @VOLVO_V70 advice on sending a private message. i clicked the avatar but no message box to be found. So this newbie needs even more advice…:thinking:

forget this post the problem is you have to earn a little trust when your new before your granted the privilege to PM. Thanks for your time.