1993 jeep Grand Cherokee 4.0L 6cyl 4wd

jeep
grand-cherokee

#1

I bought my car used. At the time when i started it it ran real loud and what id describe as “bubbly” and ouder than i thought it should but it was a cheap car…and it was from my moms hubby at the time… Last year i had to completely rebuild the transmission… now ever since when i turn car on and press on gas it hesitates… i never git it looked at… (stupid, i know) anywayd more recently it has been hard to accelerate up hills on the freeway…etc its like i have to stomp on the pedal…Nd it seems like the mim i put gas in i gotta put more in soon after…i drove it to the store and it drove there no sign of stalling. No sign of a rough idle. No sign of anything besides ehat it had been doing…i came out of the store an hour or two later and started the car…it was idling really rough…so i turned it off for a few mins and tried again…crank but no start and again…crank but no start…i had to call a tow. As i am waiting i try again more then ten mins later Nd it starts right up…it ran for about 7-8 mins and started roughly running i tried giving her gas and it seemed to make it worse and turns off. I was close to E on my gas tank so tow truck guy said he thinks im just out of gas but i had driven the car at a lower fuel level than it was at. Anyways i get home put a half gallon in mind you it was reading just below the second line now after half gallon it is a lil above and it has been reading correctly since i got it. Anywayz put gas in try to start it does the same thing it did at the store. Even running a few secs and then turning off. I smell a lil gas outside but not in the cab…dont kniw if its from the spilled gas from using gas can or the fuel system on her. Im thinking fuel pump… i bought a gauge but someone wants me to check the cheaper part…fuel filter first… And now i have checkex the pressure with a ga ge with the key in theon position and the gauge read 0 psi. Now when i put the gauge on gas spurtef out of the schrader valve as it should… Well i figured third try is the charm so.after tightening the gauge a lil i had my helper try turning on the car and now it wont even crank…it makes a clicking noise as if the battery is dead…i dont get gow the battery would die it has only been sitting for 4 or 5 days?.. Help help help. Furl pump??? Accelerator??? Both??? Alarm system mal function? What is my cars issue?? I say alarm systese i read that it will shut down the fuel pump…
ANYONE HAD THIS HAPPEN TO THEM?
OR HAVE SUGGESTIONS ON WHAT IT MAY BE??
PLEASE HELP… NEED MY CAR. THNX IN ADVANCE.


#2

I confess to having a great deal of trouble sorting out the details of your post, but if my understanding is correct you’re running this vehicle on an empty or almost empty tank on a routine basis. This is hard on a fuel pump. The pump cools itself with the fuel.

And it also sounds like you’ve killed your battery playing with this.

IMHO the best thing you can do is get it towed to a reputable shop to be looked at. Someone s going to need to check the battery and charging system and do a proper check of the fuel pump… with gas in the tank.


#3

I am going to do a fuse check tmrw and try to see if i can hear the fuel pump switch on? Also gonna put a code checker on it to see if anything comes up. And changr fuel filter…broke with baby. No money for a reputable shop


#4

If you have a community college or technical school there that has an automotive program, try asking the chairman of the department if they’ll look at it for you. If they’re doing fuel systems this spring semester, and they can schedule you into their lab time, they’re a great resource. Typically the labor is free and the parts will be discounted. It’s great for the students too, 'cause they get to work on real life problems… which are often more problematic than the new stuff they usually work with.


#5

It’s probably a combination of multiple extended cranks to try to get it to start, with each one draining the battery a little more, and the cold weather adversely affects the battery performance too. Suggest to use a battery charger to charge it up overnight. That should return you to a condition where it at least cranks ok … that rrr rrr rrr sound with the key in “start”. Until you get that happening, no way to diagnose & fix the no-start part of this problem.


#6

Yes yes. I do know? Im working on borrowing one from a friend. She told me tp try and jump it but she doesnt get that i dont need a jump i need a CHARGE. LMAO. I need to charge itt before putting code checker in right??


#7

I will look that up. Thanks