Join the Car Talk Community!

Discussion Rules

Welcome to the Car Talk Community!

Want to ask a question or join the discussion? Great! Join now.

Sign In Register

Flickering Oil Light

I have a 1987 Chevrolet Celebrity that on the exterior is in pretty rough shape but seems to run great overall. The car is only driven to and from work which is only about 4 miles each direction. So it is drive 8-10 miles a day 5 days a week. It starts great and doesn't seem to have any problems except for the flickering oil light. After about 10 minutes of driving the oil light will start to flicker whenever the car is stopped (i.e., a stop light or drive-through) As soon as I start to drive again it will stop flickering. This problem seems exacerbated on especially not days and it happens earlier than normal. It does have an oil leak so I check the oil often but this happens even when the oil is at a normal level. I don't really want to take the car in because it isn't worth anything and I don't really want to invest money into it. Any suggestions on what might cause a flickering oil light?
«1

Comments

  • My suggestion given it leaks oil is buy thicker motor oil(20W50) and see if it helps.

    It could be the oil pressure sensor going (relatively inexpensive) or mechanically the engine is simply well done given age likely. The only real way of telling is a mechanical oil pressure guage. That being said either way I would start budgeting for different vehicle.
  • The flickering light is telling you the oil pressure at idle is very low. This could be the fault of the sensor, but to test it you'd have to take it in and have a mechanic check the oil pressure at idle on a real gauge. Since the oil light is off when you step on the gas and the motor revs up you really shouldn't have a problem. It is very likely the oil pressure at running speeds is low too, but enough oil is moving around to do the job of lubrication.

    If you want to pull the pan, you could clean the gunk and sludge out of the pick up screen. On an older car there is a good chance this is part of your problem. Otherwise just keep the oil level topped off and perhaps move to a heavier weight oil in hot weather. If you are running 10W-30, try 10W-40 and see if makes any difference. If you haven't changed the oil filter in a while, perhaps the filter is clogged and reducing flow, another cheap thing you can do yourself.
  • If it's not a bad sensor, I bet it's a worn engine, not much you can do beside try slightly heavier oil. But it could run years this way. The symptoms are exactly what a worn engine would do.
  • A 4 mile drive is hard on a car.
    How often have you been changing the oil?
    Should have been doing it at least every 6 months, even though that was likely less than 3000 miles.
  • Thank you for all of your feedback. I will try a heavier oil to start. I do try to have the oil changed about every 6 months although admittedly it doesn't always happen that often.
  • Before you go the 20w50 route, try using a diesel rated oil, 15w40. Look for an SL rating on the API symbol, not SM.
  • I'd suggest pulling the oil pan off and cleaning the oil pick up tube going to the oil pump. I had a problem with my '88 Escort a few months ago where the oil pressure was dropping to near 0 psi. I pulled the oil pan, took the pickup tube off the oil pump and cleaned it good by spraying brake cleaner thought it and washing all the sludge and dirt from it. The oil pressure on it is better than it's been in years. This is an engine that has 517K miles on it and the oil pressure at idle is about 20-25 psi and at highway speed of 55 mph the oil pressure is about 55-60 psi.
  • Have you at least tried to eyeball the leak? I had an old pickup that behaved exactly this way. The pressure was actually fine. But the pressure sensor itself WAS the oil leak. While driving the pressure was high enough to keep the light off despite the oil blowing by the sensor. At idle, the escaping oil gave the sensor a bad read of the actual pressure.

    I replace the sensor and poof - no more leak or pressure light. I don't think this is the most likely scenario but its worth a look.
  • I missed the oil leak in your post, but "cigroller" has a good point, I've seen many oil pressure sending units crack and cause leaks. I'm not sure where the sending unit is located on your car, but I do know that on most Fords it's located near the oil filter. If the oil pressure sending unit is the problem it's likely you can remove the old one and put the new one in yourself in about 5 minutes. All the sending units I've ever had to replace on my cars were under $10. so it's definitely worth checking. It might solve both your problems, the leak and the flashing oil pressure light.
  • I'm in agreement with cigroller about the oil pressure sender. These things are cheap anyway so you could stick one in and if the light still comes on then you need to start worrying.

    The old Subarus were prone to oil pressure sending unit leaks. Some age and generally after a cold winter the plastic would start cracking or deforming which would then lead to leaks and/or the oil light flashing on.
    Some of the older Fords were also a bit prone to this.
This discussion has been closed.