Subaru Cyl 6 misfire Connundrum

subaru
sparkplugs

#1

Since I can remember (the engine has been swapped for 5+ years) I have had a CYL 6 Misfire (no CYL 6 misfire Code). The only code I religiously get is the 55 (EGR Temp sensor) I also get a 19 (#6 Injector) BECAUSE I pull the injector lead so as to conserve fuel.

Here is what I have done, in a clear, bulleted list. When you ask questions please refer to the Bullet number and either ask for clarification, or suggest another possibility. AND ANOTHER THING, PLEASE do not respond unless you have read the ENTIRE Original Post.

1). Checked compression. 160 psi (on pretty much every cylinder with maybe 5 psi variance) The EG33 is a 10:1 CR so I would say this is quite good.

2). Checked for missing cylinder by pulling Injector leads. Every lead except the #6 lead caused the idle to drop noticeably.

3). Swapped Injectors from CYL 4 to CYL 6 then rechecked leads. No change from the above test.

4). Checked Spark WITH an in line spark tester. Every coil was sparking except the #6 coil.

5). Checked for 12VDC at the coil lead. Present

6). Checked for 12VDC at the Ignitor connector from CYL 6 (in fact every cylinder). Present

7). Checked resistance in wiring From: Coil to ignitor (less than 1 Ohm), Ignitor to ECU, all leads (less than 1 Ohm), Ignitor Ground to Ground (less than half Ohm).

8). Replaced Ignitor with known good unit. (same results)

9). Replaced ECU with known good unit. (same results)

10). Replaced Front Crank Sensor with EJ22 Unit (when mine failed) See first Reply for details.

11). Used Oscilloscope to check: Tone from all 3 Crank/cam sensors, 1-3.4V feed to Ignitor. Suppliment info: Sensors were checked AT the ecu so as to ensure clean signal from sensor to ECU. Voltage to Ignitor was checked at the ignitor lead to ensure wiring was good, as well as at the ECU. Special note: both the EJ22 Sensor and the EG33 Sensor were used in this test (swapped and tested both).

12). Plugged my ECU into a different vehicle running an EG33. This vehicle DID NOT have the miss.


#2

#2 & 4) Have you replaced this coil or swapped it with one from another cylinder?


#3

ah, Yes, thank you for pointing this out. I have swapped coils with known good units, as well as plugged this coil into the lead for the #4 coil, where it did spark.


#4

I didn’t see anything about checking for voltage getting to the #6 injector coil. Have you done that?


#5

Is this a coil on plug or a lost spark system? The lost spark system has one coil for two plugs.


#6

I missed the statement about #6 plug not sparking when I replied in my previous post.

It is great you have access to scope to check things with. Does the signal on the blue signal wire going to #6 coil look the same as the yellow wire going to #5 coil? Also does the scope show the same signal form for each of the ground connections to the coils. When you checked the DC voltage at the coil was that while is was tied to the coil under a loaded condition?


#7

The obvious thing you haven’t tried is known good spark plug.


#8

THIS engine has coil on plug. and it is a ground switching application, switched by the ignitor (the ecu sends 1-3.4V to the Ignitor, the ignitor grounds the coil then releases ground when it sees this voltage)
i checked for voltage THROUGH the coil(s) at the ignitor connector(while disconnected), all were 11-13V

I have checked for signal TO the Ignitor from the ecu at the ecu connector… Each connection had the signal while cranking except for the #6 signal.

and yeah, i’ve changed spark plugs, but I know it isn’t the problem if the ECU isn’t even trying to give the coil spark.


#9

Since the signal for #6 doesn’t appear to be coming from the ECU and you have verified the ECU then perhaps the signal from the crank sensor isn’t correct. The 4 cylinder models have a reluctor with taps that spins past the crank sensor. Sometimes a tap would get broken off the reluctor and cause this kind of thing to happen.

I assume you have verified the #6 signal lead isn’t being grounded out somehow by bridging to ground.


#10

I also get a 19 (#6 Injector) BECAUSE I pull the injector lead so as to conserve fuel…

Are you trying to out engineer Subaru who actually knows what is going on? You definitely can add your own incorrect parts and modify. But of course you get the potential of problems.

Have you tried plugging the injector lead and putting in correct parts so the system is working appropriately as a whole? Otherwise you are only going to get wrong information back.


#11

@andrew_j, since this is my Daily Driver I pull the injector lead. when testing and diagnosing I certainly clear the codes, and reset the ECU. I have NOT modified the injector system. I am not trying to “out engineer” anyone, if I were, i would just build my own engine.

I am not trying to be rude, I’m just trying to find out why this engine/ecu/wiring harness is not allowing/telling the #6 coil to fire. I come in trying to make the data as clear as possible and then you come in saying “well if you weren’t stupid and thought you were smart you would do this…”

@Cougar, I have checked the tone wheel(s) there are 3 on this engine 2 on the crank, one on the drivers side cam (cam reset they call it) the teeth are all there, and i have checked clearance to the sensors, all are within .020 but no closer than .016, verified with the Scope that they give the proper voltage when spinning.

AND thank you for the thought on maybe that wire being grounded, which would immediately cause the scope to read ground and no signal, as the ECU does not give a high amperage signal to the Ignitor. I shall check this next time i work on the vehicle.


#12

The second most obvious thing you haven’t tried is a known good injector.


#13

Make sure the individual metal female connectors to igniter & coil #6 are making a tight connection.


#14

“I also get a 19 (#6 Injector) BECAUSE I pull the injector lead so as to conserve fuel.”

Of course you will get a mis-fire code if the injector is unplugged.


#15

Actually i do not get a missfire code with the injector unplugged.

and in switching the injectors between 4 and 6 I have confirmed the injectors are working as well I get a wet plug if the injector is plugged in.

I shall triple check the connections on the coils and ignitor.


#16

Just so I understand. Using the scope:
no signal from the ECU to #6 at the ignitor?
#6 connection from the coil to the ignitor doesn’t open to ground?


#17

no signal from ECU to #6 Ignitor at both ignitor and ECU (granted, if it is dead short to ground, the Scope probably wouldn’t sense voltage anyway which i have yet to test)

#6 from coil at the ignitor has 12V and when grounded and released, gives spark at the Plug.

it is looking more and more like Cougar had it right… Though I have been driving my spare car for a while, i have yet to had time to test.