Starting trouble


#1

i’ve got a 2000 chevy impala 3.4 v6 E.
runs great once it starts, but lately that takes a lot of cranking. it’s getting spark. it’s got a new alternator, battery, starter, plugs and wires (and i checked for spark already) I think it’s a fuel issue but don’t know where to start looking because it has no other problems. there’s no smoke or noises, no misfires, or hesitations. i put in a new fuel filter. i have heard that it could be the fuel pressure regulator or maybe even a leak in the line that’s causing it to not get pressure. i can’t hear any sort of fuel pump sound (maybe i’m deaf) is there a way to check this without a gauge? i simply don’t have one and don’t have the money to take it to a shop. p.s. i recently replaced both o2 sensors, but i can’t see how that would effect the starting. pump, hose, regulator, fuse?


#2

The next time you know this starting issue is going to occur, instead of immediately trying to start the engine, turn the ignition switch to the run position so the dash lights come on for two seconds, and then turn the ignition switch off. Repeat this a half dozen times and then try starting the engine. If the engine starts right up and runs smoothly the problem is most likely with the anti drain-back valve on the fuel pump assembly.

Tester


#3

man, i tried that and it still didn’t work. today when i went to start it, i did just what you said and it started with only a little hesitation (better than usual), but now i have three codes popping up:

p0412: Secondary Air Injection system Valve A Malfunction
p0452: EVAP emission control system pressure sensor LOW
p0453: Evap emission control system pressure sensor HIGH

Could it be an air issue instead of fuel? as far as i knew, all three of these codes are simply for emission reduction at startup, but won’t affect the actual drivability or start of the vehicle. Could the computer be seeing a fuel issue as one of these? I loved the days when a car ran on mechanical parts…


#4

I’d work at getting the codes solved first, this is likely where your problem lies.


#5

thanks FordMan59, I’m trying to diagnos that now.