Jeep Compass limp mode, rough idle, lightening bolt

jeep
compass

#1

2010 Jeep Compass…on start up idles up to a little over 1500 rpm and is very rough, occasionally it dies. Has no power. Will not get above 25 mph. I have reset ecu by taking the negative battery terminal off. I tried pulling codes by turning the key to the on/off position 3 times but it doesn’t give me any codes just sits there for a few seconds then says done. I have no idea whats gong on. Any suggestions or advice appreciated.


#2

What event(s) preceded this mystery?
Year?
Miles?
Engine choice?
History?
Without a whole lot more clues, the only suggestion I can make is to take it to a shop. Sorry.


#3

HI, thanks for the reply.

2010 Jeep Compass. 2.4L 4x4 CVT / 100,500 miles

About 2 weeks ago I was headed home going about 60 when the red lightening bolt came on and the jeep slowed down to around 25-30 mph and went in to limp mode. rpm would not get any higher than around 2500 with foot to the floor. I was only about a mile from my home so I limped it home. Once home I turned it off and let it sit for a couple minutes. Started it back up and its like it never happened. Red lightening bolt gone. So, yesterday same thing happened except this time its staying in limp mode. Also, idle is really rough and is around 1500-1800 on start up. It has died a couple times on start up. I have removed negative battery terminal to try and reset the ecu and that didn’t help anything. I have tried turning the key to the on and off position 3 times to get any codes and it doesn’t give me any, just gives me a dotted line for a few seconds then says “done”. Before this happened, my transmission light would come on occasionally but always drove normal. I have a tps light on but that’s bc I had a broke valve stem and I didn’t replace it with oem just a normal valve stem. Other than that Ive only had to replace a wheel bearing I’m guessing due to the spacer kit and the larger tires. Also, the traction control light is on as well as the 4x4 light. But again, sometimes they don’t come on, I’m very confused.


#4

If it is in limp mode with the warning lights on there will be fault codes in the PCM, You will need to get a scan tool and read the faults. There is possibly a problem with the electronic throttle control.


#5

The “lightening bolt” is the trouble light for the drive-by-wire (electronic) throttle body.


#6

To ask the plainly obvious question… have you checked your owners manual for what that red “lightning” bolt means?

I have a Dodge, and I believe the light you describe relates to the electrical system (battery or alternator).


#7

Electronic throttle control malfunction;


#8

*Update *
Just removed the electric throttle body and inspected. The plate wasn’t sticking or damaged. I cleaned it and put back together. Still doing the same thing. The plastic gears inside the electric throttle body may be damaged but I couldn’t get it apart to inspect.


#9

Yes…that is the light I have as well.


#10

I have checked the battery and alternator. Both are good.