Injectors not pulsating

plymouth
laser

#1

Hey Guys,

I have a 1990 Plymouth Laser RS 2.0 N/T. My injectors aren’t pulsating.There is supposed to be a positive current through the injectors when you turn on the key and the ECM sends a negitive charge to pulsate the injectors. My ECM is fine and also the fuel relay. The injectors are not clogged and meet specs.the fuel pump is working fine and sending fuel to the rail.The only code I’m getting from the ECM is the coolant temp. sensor and that wouldn’t keep the injectors from firing. I checked the harness for breaks and touching wires and everything checked out. If you could help me out with this I would really appreciate it.I’m at witts end here. Thanks


#2

It needs a signal indicating crankshaft/camshaft position. Have you checked the CPS sensor output? Are you getting spark?


#3

Yes the camshaft sensor is fine and yes I am getting spark.


#4

The ECU usually controls the ground side of the injector circuit. If you haven’t verified that 12 volts is getting to the injectors yet I suggest you do that. If that is ok then you need to check the ground side of the injector wiring to the ECU for a problem. It would be rare to have multiple ground wire connections go bad so the trouble may be inside the ECU. You stated that the ignition is working so that should allow the injectors to turn on. I am assuming that is the way your system works, as I know others work that way.


#5

I’m getting mixed signals from the injector wires, yesterday I was getting 12 volts from them, but now there is nothing. I’m not sure what could be causing that. Should I do a full check of every major component again? I didn’t do anything different I just decided to check again for assurance.


#6

If the sensor signals all meet spec, and the wiring has been checked for continuity and shorts (be sure you have the meter on a high ohms setting so you can catch high resistance shorts), and the signal from the ECU to the injectors is erratic, I’d have to suspect the ECU itself.


#7

I’ve tested the ECM only for codes,Im not sure how to go about testing the ECM as a unit.I have 2 other ECM’s and I get the same result.If you can let me in on how to test the ECM as a unit I would greatly appreciate it. Thanks.


#8

If you’ve already tried subbing in 2 other ECMs and gotten the same result, then I’m stumped. Have you checked the signal from the crank speed sensor? Perhaps the ECM doesn’t know the crank is turning. It needs its speed as well as its position.