Idling problems


#1

I have a 2000 volvo S40 19T, it starts up, and will run just fine if you give it any amount of gas, but it just wont idle. I unplugged the MAF sensor and it ran the same. I then took the IAC valve off and put a towel over the port (To let some gas in but not completely shut it off) It runs GREAT like that! I kept the IAC plugged in and the towel over the port, started her up and put a lot of pressure on the towel to cut of all air, the car idle went really really low and then it shut off. Now since the car knows it is stalling, and it needs more air I should be able to see the IAC opening and closing (Remember it is plugged in, but in my hand), it didn’t move at all!

Well 180$ and one new IAC valve later we still sit with the same problem. I have run the car with my towel over the IAC ports and chased all around the intake manifold and other intake duct work with carb cleaner to try and fine vacuum leaks to no avail. I even did the towel trick with a multimeter hooked up to the wires that plug into the IAC valve, it is getting a small amount of voltage, say 2 to 3 volts, but the new valve still wont open, and I have yet to confirm that the current changes with idle fluctuations when I press on the towel.

I am running out of ideas! I tried unplugging the battery to clear the ECU so it would restart with the new IAC but that didn’t work. Please give me some tips!

Is it possible it really IS the IACV and I was given a lemon?!

Thank you!

-Dave


#2

The IAC only works when the computer tells it to, and the computer will only give it directions if it knows your foot is off the gas pedal. Right now, I don’t think it knows that it is supposed to take control of the idle.

Either the throttle position sensor or a separate idle position switch will tell the computer when to take over the engine speed. I don’t know offhand which device Volvo uses. But either that device is malfunctioning, is mis-adjusted or the throttle is not closing completely.

Most of the time it is the latter. That can be due to either a dirty throttle body or the throttle stop screw is misadjusted.

Many people mistake a throttle stop screw for the idle adjustment. That is not its purpose. It is there to keep the throttle plate from damaging the throttle bore when the throttle is suddenly closed. You back the screw out until there is a gap, then tighten until the gap just disappears. Actually it should never be messed with in the first place.


#3

Wow, great advice! I was wondering why those screws existed if it wasn’t for the idle! I will check these things tomorrow! Thank you! Is there any way I can check electronics like a TPS shy of replacing them?
-Dave


#4

Okay, I have an update, I took the throttle body off and cleaned it to a mirror finish. I hooked the old IAC up to a small power converter and it opened up! So I think it is safe to say the original IAC is NOT the problem, and is just fine. I assembled everything and took the TPS off, put my towel over the IAC port and started the car. I turned the TPS a little with a screwdriver and the speed of the engine changed. Additionally when the TPS was in the “closed” position and I tried to stall the car the IAC still wouldn’t open. I would say it is safe to say that the TPS isn’t the cause of this problem either.

I rest very confidently that the big problem here is that the IAC isn’t getting current to open when it should open, or any current at all for that matter. How can I keep working on this problem? Go get a code reader and try to erase come codes? I am at a loss here.

Thanks!
-Dave


#5

Additionally, the car runs very rough between 1,000 and 1,500 RPM, below that around 700-900 it runs very smooth, and above 1,500 it runs smooth as well.