I made a boo boo with my car

kia
optima

#1

Greetings ladies and gentlemen, brand new here so I apologize as I’m still learning the ropes here. This is also going to be a long story and I hope I don’t leave anything out. SO this all begins about a month ago. I was putting new spark plugs in my 2005 Kia Optima LX 2,4 4Cyl. The car battery was dead so i didn’t get a chance to test it afterwards, fast forward a week and i have to get the car jumped and I notice she sounds horrible, she’s puttering, it sounds like quiet back firing. There’s a horrible smell of sulfur I kill the car within 30 seconds to a minute. I learned this was because I miswired the spark plugs. I eventually rewire them correctly but since that initial incident she will crank but not turn over. The first thing I did was replace the battery because the existing one was bad. Now she would crank, not turn over and I noticed the dash lights were not coming on, just the check engine, oil and those lights. The open door light and chime would still work as well as getting the odometer reading. I scanned by Car with a bluetooth OBD scanner and I could read the scanner but no reading from the computer. We also did a test to check the spark plugs for spark and no plugs were sparking. I put brand new spark plugs in after this, I replaced the ignition coils and wires, I thoroughly checked fuses both in the engine bay and under the dash There were 2 unrelated fuses that blew. I also checked the main 140A or whatever it was fuse and it seemed fine. I then replaced the Ignition control sensor, no difference, I changed the ECM relay behind the radio, no difference. I then (I do specify here that I disconnected the battery before doing this I didn’t do this with the other replacements) I disconnected the ECU and replaced that both times with the battery disconnected. Still no dash and no turn over. At this point I’m at wit’s end. A local monro mechanic told me he tested and got no fuel pressure but this was also with the ECU disconnected so I wouldn’t imagine any fuel would be read. I haven’t tried reading fuel with either ECU connected, At this point Idk what else I can try, IDK if it is the computer related and if so what else I could be missing. I severely need some assistance.


#2

These are normal until the engine starts. You can discount this as a symptom.

No disrespect intended, but exactly how did you determine that you rewired them correctly?

Does your car have an antitheft system that disables the fuel pump if it detects a theft attempt? Read your owner’s manual to find out and post beck the answer.

Excellent deduction. With the ECU disconnected, there’s nothing telling the injectors to fire. If his “test” was to see if the injectors were firing, he would see no fuel. If his “test” was by checking the pressure at the fuel line or manifold, he should be seeing pressure with the key in the ON position even if the injectors aren’t firing… unless you have the aforementioned fuel shutoff antitheft feature.

My gut suggests the problem is ignition related rather than fuel. The sulpher smell suggests that something got fried, but I cannot think of what to suggest other than the coils. Perhaps someone else here can add to this possibility. Sorry.


#3

This was alot of help.
In regards to your first statement. I could’ve sworn that it was normal to see those lights when turning the key to the on position.
To the second statement. I looked in the manual at the firing order and did some research on it. So cyllinder 1 was wire 1, cyllinder 2 was coil 1 which connected to wire 1, and cyllinder 3 housing wire 2 and cyllinder 4 housing coil 2 which connected to wire 2. It should have been cyllinder 1 connecting to 4 and 2 connecting to 3 in stead of consecutively.
I will report back about that fuel pump disable. I do have a viper alarm system but I don’t believe that would interfere. I also wasn’t sure if I somehow knocked the inertia switch assuming this car even has one.

I would imagine the mechanic did the fuel pressure test but I would have to ask him myself. One of the coils after the intiial test was fried and by that I mean I couldn’t get a resistance reading where as the other read around 21k ohms I believe so it’s definitely possible that was my smell so i put one of the new ones on. Definitely some things to look for.


#4

That’s what I was hoping to hear. Nice work.

That could definitely be interfering with your ignition’s ability to produce spark. I’d look really, really deeply into that one. Aftermarket antitheft systems can cause all forms of havoc if a battery is disconnected.

That’s an excellent thought that hadn’t occurred to me.

And here’s a suggestion for the future: I learned many years ago that when changing plug wires or even vacuum lines the best way to do so is to replace them one at a time. That way you never have more than one disconnected at any given time and cannot cross up the connections.
Remove one and replace it. Remove another and replace it. And so on.


#5

Concur w/TSM, focus on getting the ignition system to produce a spark as your first goal. It’s quite possible once you get that part sorted, the engine will start run normally. You aren’t the first person to mix up the spark plug wires. I’ve never heard reports here of any serious adverse consequence of that. I mean provided the car is only idled for test purposes and isn’t driven in that condition.

I expect what happened has nothing to do with the spark plug wires. It’s probably involved with replacing the battery. Something went amiss in that process somehow. For example it is possible to cause an electrical glitch that could damage sensitive electronics if anything is powered up when you disconnect or connect a battery.

Probably the biggest clue you have to go on is the two fuses you found that were bad. Which fuses were they? For what circuits? Beyond that, to produce a spark usually you need these things to happen

  • the engine must be rotating (during cranking it is)
  • the ecm must be powered up
  • the crank position sensor must be sensing
  • the ecm imust be detecting the engine rotation signal from the crank position sensor
  • the ignition module must be powered up
  • and it get a fire signal from the ecm, and then fire the coil(s)
  • the coils must be working, which then produce a spark

So start at the top and work your way down. You already know the engine is rotating during cranking, so item 1 in already ticked off. Next up, is the ecm powered up ok?


#6

Ok so I will go as far to say I know what most of that means…that’s about it. I don’t know how to test any of the other items other than the coils because i checked their resistance which both measured around 21k Ohms. I also forgot to mention I did perform the ol’ starter fluid in the intake trick and it did manage to “turn over” it started making some horrendous sound but the engine seemed as if it was trying to do something. Also I did notice she wouldn’t turn over before the battery swap. I tried jumping her and she would only crank, never turn it was just much more delayed.


#7

Sorry I forgot the two fuses that were blown were a 40a blower fuse in the engine bay I assume for the blower motor and a 15A fuse in the dash that said ACC socket


#8

You seem to be making contradictory statements. If the spark plugs are not producing sparks, the engine wouldn’t pop and start to run at all. It might make horrendous noises during cranking. But it wouldn’t pop and run (turnover) even if you sprayed starter fluid in the intake. Maybe first test is to double-check whether you are getting visible sparking or not at the spark plugs during cranking.


#9

Ok, I actually found another forum on this page regarding my Viper alarm system and the suggestion was to simply disconnect and reconnect it. I think that will be one of my next tests. But yeah it would crank sounding fine but when I sprayed fluid in and cranked it would do some kind of gurgling popping idk what to even call it. So maybe it is related to fuel intake after all. My biggest challenge right now is the car is still sitting at the monro mechanic. and although they overall dont care if I’m there working on it a bit, It’s not ideal for work. I also apologize if I’m missing details here and there I also have one of those dealership antitheft devices that disables the starter. The one’s that have a key combo for missed payments. I do know the code for that and i’ve made sure it goes green when i unplug the battery. I’m not sure the best way to reliably test the spark. I know i grounded the plug against the head near the cylinders and it didn’t seem like I was getting anything.


#10

This car uses the coil on plug method right? One way to test for spark, remove a coil from the installed plug and install a spare plug in that coil. Hold the base of the plug against a metal engine ground while a helper cranks the engine. Be careful b/c it is possible to get a nasty shock doing this. Wear thick rubber gloves and don’t touch or bush up against any metal parts with any part of your body. Do you see a spark at the tip of the spark plug?

If any of this makes you feel uncomfortable, give this job to a shop instead. Any shop can tell you without much time or effort whether you are getting spark or not.


#11

Perhaps you didn’t dispense enough starting fluid into the intake manifold. I don’t know the delivery rate of the can you are using but we use brake cleaner because it is all over the shop, 3 to 5 seconds of spray before stating will get the engine to run for about 10 seconds.


#12

Viper after market alarm - selling dealer installed gps kill system add that to all the other problems and this is going to take a lot more diagnostic than can be done over the internet.

Usually there is not a way to tell if the dealer has installed the remote disable system so that green light might be for something else and the dealer will not give you the code.


#13

The smell most likely is due to a plugged or broken catalytic converted. If you get your car to start again check your exhaust system after the converter, you may actually see dripping leaks.


#14

Sounds to me like he’s got a 4 cylinder engine with a waste spark ignition system

He did say 1 and 4 go together and 2 and 3 go together

That would make sense, as 1 and 4 are companion cylinders, and 2 and 3 are the other companion cylinders

ff one coil has totally failed, meaning no spark to either of the cylinders it supplies, that would leave just spark for 2 cylinders

I could imagine a 4 cylinder with spark on only 2 cylinders might not start at all

I believe OP said one of the coils was bad


#15

Wasn’t there a VW model that had 5 ball joints on each side of the front end?


#16

Huh? Are you sure you didn’t accidentally post to the wrong thread?


#17

Must be one of the more recent models, with multi-link front suspension . . . ?


#18

In this thread we’ve been discussing an engine operating problem.
If suspension type has something to do with this, the connection is beyond me.


#19

Hey guys, just wanted to give an update. I ended up taking it to the mechanic because I just gave up on my own. I should’ve admitted defeat long ago. I truly appreciate everyone who took their time to contribute and either way I’ve gained alot of knowledge what to look for in the future. The local mechanic diagnosed that the immobilizer looked like it was wired by a child. No soldering was done whatsoever and once he disconnected it properly, the dash lights lit up, he regained elctrical flow to the o2 sensor, fuel injector and the ECU. None of those were getting power at the main fuse box. The car hasn’t been started yet but it definitely looks like the main issue will be solved.


#20

There are 2 components involved with IQ, chronological age and mental age. It probably wasn’t a child (by chronological age) that did a botched wiring job, but more likely a real dolt. :wink:

Personally, I’d never cut, splice, tap, etcetera, a wiring harness in any of any vehicles, nor would I allow anybody else. I go to plan B.

I once wired trailer wiring into my car (it had provision) by using harness pigtails from a salvage yard from a vehicle of my make/model that allowed the trailer wiring to be unplugged and removed if desired, returning the original harness to original.
CSA