CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

HOW to check powertrain control module on my 96 cherokee 4.0

after a year of running perfectly, yesterday I tried to start my cherokee, it cranks, wont start.

fuel pump is not producing pressure, check engine light does not come on in “run” mode.
I jump relay socket at fuel pump relay, pump comes on, swapped relays ,still no pump action,… with ignition at run position, I get batt voltage at plus side of relay coil so the ignition switchis likely good, when I connect obd scanner I get a communication error . The powertrain control module is not shorted to gnd as I checked for this common problem.
Any other way to test powertrain control module before I shell out $200?
I have a fluke multimeter and an obd scanner

Will the engine start and run if you hot-wire the fuel pump?

With no check engine light coming on with the key, I would be checking for a blown fuse. Sometimes they put some oddball stuff in the same circuit as the power to the ECM, like the cigar lighter.

I agree with @mark9207. More than likely the problem is just a blown fuse in the panel under the hood.

Ill go with you have no power to the engine on keyswitch position. You did not say whether the normal dashlights come on? If the computer has no power then nothing happens. Trace that first.