Error codes P0011 and P0012

nissan
code
altima

#1

My daughter Emily has a 2005 Nissan Altima 3.5, manual transmission. Right after she picked up her car from the transmission shop (not the dealer) that had installed a new clutch (at 43,000 miles), her check engine light was on. The error codes were P0011 and P0012, which I understand involves the IVT solenoids, one in each bank. There was also a slight decrease in power. We took it to my Nissan dealer, who replaced both solenoids. The problem remained. [I didn?t really think it was the solenoids ? it seemed highly unlikely, if not impossible, that they would both go bad at exactly the same moment. The dealer didn?t charge for the solenoids, but did for the labor.] The dealer then gave us an estimate of $1,650 for the next repair, almost all of which is labor. They say they have to take off the whole front of the engine to get at the cams or cam sensor or something like that.



I got a chance to talk to the Nissan mechanic, and asked him about the coincidental timing of the IVT error codes appearing right after the clutch was replaced. He suggested that when the transmission shop put the flywheel back on after turning it, they might have put it on a tooth or two from the position it should be in. He said that could make the P0011 and P0012 error codes appear and cause a loss of power. Does that sound right to you? Would you expect a transmission shop to make that kind of a mistake? Aren?t there alignment marks on the flywheel? [The repair would cost the same as replacing the clutch because they have to take it out to check the flywheel. I?d have to pay for all that labor even if it turned out that the flywheel was properly replaced, and it wasn?t actually the problem.]



Also, does taking off the whole front of the engine (whatever that means – the valve covers?) seem the way to address the problem? I?ve read that because the IVT solenoids operate on oil pressure, dirty oil or a gunked-up crankcase can cause the error codes. But, just 200 miles before the clutch went out, Emily had the oil changed. She uses full synthetic. She?s only had the car for about six months. It had about 40,000 miles on it when she got it. I don?t know how diligent the previous owner was doing oil changes. (Though he apparently drove the car hard enough to require a new clutch after only 43,000 miles. Shouldn?t a clutch on a 2005 car last 100,000 miles?)