Electrical problems with the blower

'02 Cavalier with 165k. The blower went out. It was working off and on (sometimes with a tap on the blower housing) for a few days. Took off the blower housing and the resistor. The resistor looked blown ( this maybe after I took the cover off and started looking at it). I replaced the resistor–still no power. I replaced the blower relay under the hood–still no power. The fuse in the cabin marked HVAC is good. The AC will come on and I’ll have cold air tricking out of the vents while the car is moving. The vent and defroster will switch back and forth–but with just a trickle of air when the car is moving. Everything else on the heater/AC panel seems to work but the blower. A test light placed in the socket for the resistor won’t light.

So, are there anymore fuses/relays/circuit breakers, etc. that I should be looking for? Any ideas short of taking off the dash? Where do I go from here?

You should probably check the switch itself. Best to have a multimeter. Pull it out see if power gets to it - then see if any power gets out.

Perhaps the blower motor itself is the source of the problem or if your lucky just a bad connection.

I would start checking things with a meter. Find out where the power really stops or if (as I suspect) it is the motor.

How could it be the motor? Power isn’t getting there in the first place. The wires run from the resistor to the motor and there’s no power in the four sockets of the resistor socket.

Here’s one scenario; the resistors are the “ground” side of the circuit. The motor has +12 going to one side and the other goes to a switch selectable load resistor to set the motor speed. If the motor winding is open, you will not see any voltage on the resistor block. I don’t know if your system is wired this way, you will have to check the schematic, someone with specific knowledge can weigh in or you can check the other feed wire to the motor to see if it has connection to +12 or GND.

The motor is totally disconnected right now and there’s no power getting to the resistor socket, as shown with a test light. Would this fit into your scenario?

There’s basically two ways it can be configured- the +12volts is supplied to the resistor block and the outputs from the switched load resistors are then connected to the blower motor. The blower motor is grounded through its housing to the chassis.

The second way would be to have a +12V feed to the motor and then connections to the switched resistor block which provides the ground path.

If there is only one connector going to the blower motor and none of the pins have +12 on them, then you have to check the other wires feeding the resistor block to see if they have the +12V feed. Be sure you have a valid ground for your test light. It should illuminate on some other known +12V source. Sometimes, not all dash braces are good electrical grounds to the chassis.

I’ll try to look online tonight to see if I can find a schematic for your car so we can be more definitive…

I agree with TwinTurbo about the power going to the motor first. Most blower circuits run the power to the motor and control the motor speed on the return side of the circuit. To see if the motor is functional try running power directly to it. If that works then the trouble is most likely in the switch area.

Even though the motor may be first in line with the power you should see voltage getting to the resistors if the path through the motor is ok and power is getting to it. Voltage will be at wherever the high resistance or break in the circuit is at. If the motor brushes are bad then voltage will be stopped at the motor connection. Whatever is tied to the other side of the connection break will be at ground potential, until the circuit is completed and current can flow again in the circuit.

Hooked my blower up directly to a car adaptor and it spun just fine. Does this mean the switch is the problem? Does that mean taking off the dashboard to get to it?

Check to see if you have voltage getting to any of the wires going to the motor. If you do then the trouble is most likely with the switch or possibly the ground to it. If power is getting to one of the leads of the motor you should be able to manually ground the other side of the connection to the motor and turn on the motor but you have already proved the motor is ok. This would verify that power to the motor is ok and the trouble is on the return side of the circuit.

Depending how the blower switch is wired it could be possible that if the ground for the switch is bad it may prevent the blower relay to turn on and so no power would get to the motor.

I found some data for this on the Autozone website. There is a main fuse in the panel under the hood for the blower so check that out. If that is ok then you need to see if the blower relay is ok. It is turned on by selecting one of the Mode switch positions. If the relay is ok and power is getting to it then the purple wire going to the motor should have voltage on it. By grounding the orange wire of the motor the motor should turn on. If that works then the trouble is most likely with the speed switch since you already replaced the resistor pack. The hight speed position bypasses the resistor pack and is supposed to apply a direct ground connection to the motor.

Because the blower motor spins when hooked to 12 VDC does not mean it will spin when fed with the 9 VDC or 6 VDC that is the reduced voltage with the resistor leg in the circuit. The resistor works by “dropping” some of the voltage, leaving less for the DC motor to operate off of. That’s how the motor speed is controlled.

Besides, a good DC fan motor will operate with little voltage applied. I’ve tested this myself on a test bench using simple AC/DC converters of the type used to recharge nickle cadmium batteries. If yours would sometimes work when tapping the housing, it’s almost certainly the motor.

And, a binding motor can cause current draw sufficient to fry other things like the resistors.

I would think the fuse would open before a over current situation caused by a binding motor would last long enough to damage the voltage dropping resistor.

Perhaps. But the only other option to dry the fuse would be a spike. And that would blow the fuse too.

My money is on the blower motor. It’s exhibiting the regular symptoms.

I have to say the motor is ok. He proved that it worked ok by applying power directly to it. He also stated that power isn’t getting to the resistors. Since the motor worked and is in series with the power before the resistors, he should have seen power at some point there if power was good. The motor isn’t even running at full speed so either the main fuse under the hood is blown, or the speed control switch isn’t making a ground connection (he should have at least seen voltage at the resistors if that is the case). Since the vents are working it seems the Mode control is working and should be suppling power to turn on the blower relay. So to me it points to a bad fuse under the hood or power wire connection as the most likely suspect.

To address the question about the dashboard if you want to check the switch - normally you just have to pull the bezel(s) around the switch - its not major surgery.

At this point I think you should go get a repair manual. It will give you step by steps for checking the fan curcuit/resistor/switch etc. in a logical manner. It will also tell you how to pull & replace the switch if necessary.

Oops, I forgot about this thread, my apologies to the OP.

Oldschool, my 2004 Trailblazer roasted the resistor block without ever blowing the fuse. A chipmonk or mouse decided to store some of his acorn stash in the blower fan (how appropriate, it’s known as a squirrel cage, eh?). The extra load on the motor fried one of the resistor pack’s legs. When I took it apart and found out they wanted $50 for a new pack, I decided to fix the old one. Been working fine ever since. But the fuse did not protect the resistor pack. I suppose a completely bound up motor would draw enough to allow the fuse to blow before enough heat built up on the load resistor but if the load is gradually more severe as time goes on, I can see the pack blowing, especially if the speed is low and the cooling effect of the duct air is insufficient.

I decided to go through every fuse before doing anything bigger. While going this, I found a blown fuse in the compartment under the hood with a scratched label. And this was the bad one. Got everything reconnected and everything is working now. What threw me was, I assumed there would only be one fuse for the blower.

Good deal. Glad you got it and thanks for the feedback. Since you stated that you saw no voltage at the resistors I figured it was a bad fuse that may be the cause of the trouble after looking at some data. The other fuse you first saw is for the mode selector switch which ties to the relay coil.