CarTalk.com Blogs Car Info Our Show Deals Mechanics Files Vehicle Donation

Electrical/accessory problem

99 volvo S70. When I start my car (either turn it to start or physically start it, the power windows/radio/blower and wipers do not start for right at 2 minutes. Also the SRS and service engine light come on. The lights/blinkers/door locks and gauges/clock all work from the get go. Once the accessories start, the SRS and service engine lights go out.



I have replaced the ignition switch.



If I turn the car off and start it right back up, everything works fine. If it sits 10 or 15 minutes, the exact problem occurs.



Is my car haunted?

May I have the envelope please. The winner is, the overload relay x-supply.

There is a relay in the central electrical unit (I assume that is the dash fuse panel) that appears to be the common denominator here. It supplies power to the areas you mentioned along with some others such as the horn. My money is on that relay as the cause of the trouble. There are at least two in there so be sure you pick the correct one. Hopefully they are marked well on the cover to the panel.

The volvo people laughed at me and said there is no such part and I would need to bring it in for extensive testing. They said it would take an expert technician probably hours to diagnose because none of these items mentioned are connected to one another. I find this as believable as politicians ads.

Well the info I gave you shows the relay in the drawing. I don’t know why they would laugh at you. When problems like the one you have happen it is pretty common knowledge for a tech to try and find a common connection point to try explain how the problem is occurring to the different circuits. A faulty relay is a common item to fail in a manner you described. I guess the joke will be on them if that works out to be the problem (an I 85 percent sure it is) and you tell them you found out the answer to the trouble by spending 10 minutes on the internet plus saving a lot of money on a service charge that really should only take about 1/2 an hour.

Here is some follow up information about the relay I mentioned previously. It is controlled by a circuit coming from the ignition switch using a yel/vio color wire. That wire also ties to the SRS system so it is possible that the relay is ok and the trouble is really with the ignition switch. The same wire also ties to the roll bar control module and instrument cluster so they would be effected also if the ignition switch is the trouble. I’m not sure what the instrument cluster wire is powering but you stated things were ok there so this may indicate the switch is ok.

The SRS fault light is thing in question here but there is a circuit tieing through the relay that supplies power to the seatbelt buckle latches. Losing power there may cause the SRS light to come on and so this would help verify the relay is the problem. One thing I can’t explain with the relay theory is why the CEL light is turning on. It may be that there is something on the instrument cluster lead that is causing the CEL to turn on. This then points to the ignition switch as the trouble.

Edit: I read your original post again and forgot you stated that the ignition switch was replaced already. If swapping out the relay doesn’t help then the yel/vio wire needs to be checked for a connection problem.

I really appreciate your diligence. I have no doubt you are correct. I just read about a person having a similar problem on the same car but his problems were lights, door locks, instrument gauges etc. - all the items that start right up for me. Basically, I surmised a couple of months ago that all these accessories were split in 2 and all went through 2 separate relays after the ignition switch. There really can be no other answer except for the wire connecting the relay to the ignition. Once again, thanks for all the input.

You’re welcome for the help.

If the two relays are identical you could try swapping them and see if the trouble moves with the relay but that may cause some other problems you don’t want while driving.

It sounds like you have a good handle on the way things work so you should be able to find this problem without much trouble. I tried to find out where the Central Electrical Unit is and the best that I find is it may be under the hood near the windshield, under a cover. Have you located it?

IT WORKED. At least so far and yes it is right next to the windshield. You have to unscrew 4 screws and there they are. Thanks a lot and I put this link on volvo forums for a person having the identical problem. Seems you have a better handle on it than the volvo mechanics. Thank you.

Good deal. You’re welcome for the help and thank you for the feedback.

It looks like replacing the relay with a new one will fix you up if you just swapped the two to check it out. I guess you are the one laughing now; over the money you saved from the long hours of service time the shop predicted that would be needed to fix this.

Yes, it feels good to have fixed it without taking it to a dealership for lots of moola. For anyone experiencing the same problem or if you have lights/power doors/instrument lights problems it is the same fix, other relay here is the fix. Both relays are the same. The one closest to the passengers side is the one for my problem and the other closest to the driver is for the lights/doors/inst. panel gauges. You must remove the 4 screws around the fuse box closest to the windshield/driver side and you will see the 2 gray square relays. They simply unplug. Pull straight up. Part no. 9494424 and it is called a relay.

I have another problem Cougar. My instrument lights and shifter lights do not work. All the idiot lights work, heated seat lights, visor mirror lights work as well as lights above the mirror. Glove box light works as do courtesy lights. All out side lights work/headlights, blinkers etc. Radio light also works. Fuse is fine and the dimmer switch has no effect. Also, turning the headlight switch to different positions has no effect. I just had the oil changed at the volvo dealership. Could a software upgrade have any effect? If not, then the dimmer switch must be defective? Could it be anything else Cougar?